Unable to boot home assistant in virtual machine / starup.nsh error

Tags: #<Tag:0x00007fc3dea09570>

I am unable to boot home assistant in virtual machine on my windows computer. I get to “Shell>” and then nothing else. I tried trouble shooting by following this https://www.youtube.com/watch?v=YCegkcVheJA I get to “bootx64.efi” , press enter and nothing happens.

What I think the problem is: virtual machine does not know what file to use to boot. I downloaded linux to use as a “startdisk” .iso file to boot from but, it just boots it up and tries to install it…

I am lost. I will try to take screen shots.

Thank you for your help in advance. I am very excited to go down this home assistant path, but having some hiccups.

1 Like

Have you enabled EFI boot?

bled svm in my ASUS BIOS. Those two things got me to where I am now.

I have it set up for linux but should it be windows? or something else

My pointing device is “usb tablet” does that make a difference? I wouldn’t think so, but I really don’t know what I am doing.

In virtual box. Not your main system board.

Wile in virtual box, Right click your Hass vm install an click settings. on the left panel as seen from your pic.

I don’t think it would.

Hi,
Has anyone found a permanent solution to this? I am having the same issue on a Windows host. Does not happen with Ubuntu.

Every time I reboot the Windows host, Virtualbox is unable to start my HA VM and goes to the EFI shell. There is nothing in the FS0:\EFI folder. I have to restore my Virtualbox snapshot for it to be able to start the HA VM.

Thanks for any help.

Same issue in here.
Working but in need of a fix :slight_smile:
Thanks

Had this issue as well, basically my VirtualBox VM stopped working after the latest upgrade. After a bit of investigation I figured out that the issue was in corrupted data inside the hassos-boot.img partition, i.e. the FS0:\EFI folder had zero size and the BOOTx64.EFI file wasn’t there.

The simplest solution that I’ve found so far is to mount an additional hassos-boot.img inside my VirtualBox VM:

  1. Download the latest HassOS VDI hassos_ova-5.10.vdi.xz from here;
  2. Upack the archive using 7-Zip;
  3. Unpack the hassos_ova-5.10.vdi VDI image using 7-Zip;
  4. Convert the hassos-boot.img file to VDI format:
    VBoxManage convertfromraw --format VDI hassos-boot.img hassos-boot.vdi
  5. Go to your VirtualBox VM settings and under Storage add the hassos-boot.vdi file as a new hard disk next to your existing HassOS OVA VDI image.

Hopefully it starts and boots as expected, otherwise the new VDI should be mounted as a new drive and you can work with it inside the Shell>.

2 Likes

Thank you for providing this information!
I had to type exit and find the Boot Order option in the menu but after putting the correct one on top I could finally use my image again. I think the partitions on it ran out of storage.

3 Likes

This worked for me. For others, the option to change Boot Order is in the Mgmt option in the menu. Change the boot order so the disk on the top.

This did not work for me, However anyone in need of an ugly fix let me know as I was able to get back up and runniing

Hi guys,

sorry for my English :D. I was able to come up with some workaround.
once you land in the Shell>
1.fs0:
2.edit startup.nsh
3. now in the editor enter the location of the BOOTx64.EFI “\EFI\BOOT\BOOTx64.efi”
4.still in editor left ctrl+s = save and hit Enter to save
5. left crtl+q = quit

you can now reboot the machine, it still lands in the shell but after a 1s it starts loading.

Hope this helps for now.

Peter

2 Likes

Please bear with a novice taking his first steps into Home Assistant land, but I’m having the same issue as this thread ending up at the Shell> Please can you explain how to do the workaround, in simple terms.
1.fs0:
2.edit startup.nsh
3. now in the editor enter the location of the BOOTx64.EFI “\EFI\BOOT\BOOTx64.efi”
4.still in editor left ctrl+s = save and hit Enter to save
5. left crtl+q = quit
I don’t know how to change to fs0

Thank you @retep.zcar, you saved my life! It works!

@5haun2005 Just do it as it is written.