Unable to communicate with myLeviton service

I just recently switched from openHAB to Home-Assistant. I’m running it on the RasPi 3B+, so I wasn’t able to use Hass.io. I installed via Hasspbian. I have fully updated and added the configuration information to /home/homeassistant/.homeassistant/configuration.yaml

  - platform: decora_wifi
    username: [decora username]
    password: [decora password]

However, in my home-assistant.log file, I keep getting the error:

2018-05-13 12:23:39 ERROR (Thread-7) [homeassistant.components.light.decora_wifi] Failed to communicate with myLeviton Service.

I’m not sure what to try. I have the NEST up and running well, but I can’t figure out this Leviton Decora Smart issue. Any help?


curl https://my.leviton.com/api


{"error":{"statusCode":404,"name":"Error","message":"There is no method to handle GET /"}}

Anyone have any idea?

Have you tried the exact same username and password with the “My Leviton” app? I don’t have these and therefore have never tried them, but it appears from the docs that these credentials need to be valid for their “My Leviton” app. So I would try that first to make sure the login works. Maybe you need to do some setup via that app first for this HA service to be able to use it???

Hi pnbruckner,

Thanks for the reply. I tried the username and password in the Android app and all showed up as it’s supposed to.


Here’s some additional logs. I’ve been working with folks on discord.


Is the output of journalctl while restarting the service. Near the end you can see the error at 16:41:01. Really not a lot of helpful information. Everything checks out so far. I’ve updated python manually to 3.6 from 3.5.

Hey mtylerb,
Were you able to figure this one out? Mine was working for about a week and then stopped connecting. No authentication changes on the server side