Unable to configure RaZberry board with openzwave

I’m trying to install and configure Home Assistant to work with my raZberry zwave module.

I used raspberry pi image for installation and have followed the steps in Z-Wave - Home Assistant

My configuration.yaml has entry:
usb_path: /dev/ttyAMA0
config_path: /usr/local/lib/python3.4/dist-packages/libopenzwave-0.3.1-py3.4-linux-armv7l.egg/config
polling_interval: 60000

However, in the Home Assistant log file, there is an entry:

09:59:58 homeassistant.components.zwave: You are missing required
dependency Python Open Z-Wave. Please follow instructions at:
Z-Wave - Home Assistant
16-10-07 09:59:58 homeassistant.bootstrap: component zwave failed to

What am I doing wrong?


If you are using a PI3 with raZberry gpio mudule the onboard bluetooth and raZberry will try to use the same serial port.
If I remember right you get this message in this case.

This is how I solved it(not sure every thing is needed), this will disable bluetooth.

  • Add the user running Home Assistant to the group “dialout”

  • Edit /boot/config.txt. Add this:

  • Edit /boot/cmdline.txt. Remove this from the row
    console=serial0,115200 console=tty1

  • Reboot

I’m not sure that you have to change Core_freq when switching to uart 1
I’d also run rpi-update(might not be necessary)

thanks for your answer!

I’m not using PI3 but PI2, so I do not have onboard bluetooth.

I was actually hoping you were partly right, since I had a bluetooth keyboard dongle plugged in, and last night, I tried configuring without it. But no luck there :disappointed:

I have been able to get the Z-Way software working (http://razberry.z-wave.me/index.php?id=24) and successfully detected my devices.
Could it be that that is causing the problem? Is it possible it is somehow interfering with homeassistant?


Yes you have to disable Z-Way in order to run Home-assitant.
It’s the same if you want to run the OpenZWave control panel, disable home-assistant (and Z-Way).
You should only have one Z-wave applcation active.

OK, so I disabled both HA and Z-Way and tried the OZWCP, but again unsuccessfully :frowning:

2016-10-11 22:19:46.229 Always, OpenZwave Version 1.4.2188 Starting Up
webserver starting port 8888
post: key=dev data=\dev\ttyAMA0 size=12
post: key=fn data=open size=4
post: key=usb data=false size=5
2016-10-11 22:19:54.257 Info, Setting Up Provided Network Key for Secure Communications
2016-10-11 22:19:54.259 Warning, Failed - Network Key Not Set
2016-10-11 22:19:54.260 Info, mgr, Added driver for controller \dev\ttyAMA0
2016-10-11 22:19:54.261 Info, Opening controller \dev\ttyAMA0
2016-10-11 22:19:54.262 Info, Trying to open serial port \dev\ttyAMA0 (attempt 1)
2016-10-11 22:19:54.263 Error, ERROR: Cannot open serial port \dev\ttyAMA0. Error code 2
2016-10-11 22:19:54.263 Error, ERROR: Failed to open serial port \dev\ttyAMA0
2016-10-11 22:19:54.264 Warning, WARNING: Failed to init the controller (attempt 0)

Do the account running OpenZwave have permissions to /dev/ttyAMA0 ? Normally belong to group “dialout”.

Huh, so, I’ve managed to get it working. :slight_smile:

I feel like an idiot now, but as you can see above, in OZWCP i used \dev\ttyAMA0 instead of /dev/ttyAMA0 :pensive:
So, OZWCP did work after all.

As for the HA & OZW, it seems that the instructions were unclear, and I, being a python noob, was not aware of it.

So, I followed this: Install via Hassbian image
and then this: Z-Wave

But as it seems, I was supposed to install the openzwave in virtualenv, as described here Installation in virtualenv

So now I have installed it successfully (and updated the app in the process).
I hope my troubles will help someone else in the future.

Thanks again, roer70!

I finally got this to work based on your instructions. I do have a question though. How do you pair devices with the RazBerry daughter card?

I did that in Z-Way, before configuring HA. I guess you can do it via OZWCP as well, if you’re more fond of that :slight_smile:

Thanks for the information. Quick question. Are you noticing any kind of range issues with the RaZberry card? I can’t get my devices to work reliably with this card.

Second follow up. For anyone who stumbles across this in the future, here are the steps you need to follow to add devices to the card.:

Stop home assistant (this can be done via the GUI or your pi’s command line)
Install Zwave.me: wget -q -O - razberry.z-wave.me/install | sudo bash
Add device (http://[your pi IP]:8083/smarthome/)
Uninstall zwave.me: sudo update-rc.d z-way-server remove
restart: sudo reboot.

For now I only have a z-wave thermostat + actuator, both of which are within 10 meters of RaZberry, so everything works perfectly. My apartment is very open, and the PI is in central location, so other than taking the thermostat outside, I could not simulate any obstacles :slight_smile:

As for your steps, I did not uninstall z-wave.me, I simply disabled the service (you never know when you’ll need it again).

Hi , can you describe, how did you disable zwave service?

Assuming the service name is z-way-server and has an init script

  `sudo update-rc.d disable z-way-server`