Unable to connect a Thread Device

Hi I have a Thread sensor and I have been following this instructions to add it to HA:

It connected but only via bluetooth (the device has both bluetooth / thread) but not via thread

The thread status is shown as disabled in HA diagnostic.

I have reset and connect and tried many times but the Thread still won’t work. If I remove it from HA and connects with Homekit directly, Thread works again. However, I have to remove it from Homekit so that I can connect it to HA. Anyone experienced this? Thanks.

Did you tried this procedure : HomeKit Device - Home Assistant ?

IDK what sensor you are using so I presume it’s an Eve device ? :slight_smile:

I have a Eve Aqua, It is homekit compatible first. then thread compatible but it needs a little manipulation i haven’t got there since it require an iphone (i don’t have).

I also saw that devices could need an update of their firmware, idk if it’s your case too.

Hi it’s the Qingping Temperature Sensor.

Yes I did follow the “Adding a HomeKit device through Thread” but it only end up connecting with bluetooth but not Thread.
It’s homekit compatible but for HA to work I have to remove it from Home app first.
The firmware is all up to date.
I just couldn’t get the Thread to work even I followed those procedures.

Have you got to the point where you can obtain the Matter code ?
Such as the code here :

I am not sure how to help as I don’t know at what stages you are stuck.

From Homekit you should be able to enable thread and obtain the code.
Then you should save it and integrate the sensor with the HA companion app and the code.

If it fails at the companion app i may have a fix.

There’s no Matter as the device only support Homekit and Thread.
For that Thread integration to work I have to remove it from Homekit first.

I finally make it work by solving the HA preferred Thread network. But occasionally the Thread disconnects and the connection is back to bluetooth.