Unable to connect aqara cube with ZHA

Hi everyone,
after a long time (tipical with aliexpress shippments) arrived my aqara cube and I am not able to connect it to HA with ZHA, the device seems to be found by my coordinator, as you can see in the image below, but after several retries getting timeouts the process ends and no one device or entity is created in my HA.

In case it helps, I have a cc2531 with latest firmware (CC2531_DEFAULT_20201127)

This is the entire log :

Device 0xd1ca (00:15:8d:00:06:ec:3b:3c) joined the network
Device 00:15:8d:00:06:ec:3b:3c changed id (0xd1ca => 0xd1ca)
[0xd1ca] Scheduling initialization
Tries remaining: 3
[0xd1ca] Already have endpoints: {0: <zigpy.zdo.ZDO object at 0x7fa1f83e50>, 1: <Endpoint id=1 in=[basic:0x0000, identify:0x0003, ota:0x0019, multistate_input:0x0012] out=[basic:0x0000, groups:0x0004, identify:0x0003, scenes:0x0005, ota:0x0019, multistate_input:0x0012] status=<Status.ZDO_INIT: 1>>, 2: <Endpoint id=2 in=[] out=[] status=<Status.NEW: 0>>, 3: <Endpoint id=3 in=[] out=[] status=<Status.NEW: 0>>}
[0xd1ca] Initializing endpoints [<Endpoint id=1 in=[basic:0x0000, identify:0x0003, ota:0x0019, multistate_input:0x0012] out=[basic:0x0000, groups:0x0004, identify:0x0003, scenes:0x0005, ota:0x0019, multistate_input:0x0012] status=<Status.ZDO_INIT: 1>>, <Endpoint id=2 in=[] out=[] status=<Status.NEW: 0>>, <Endpoint id=3 in=[] out=[] status=<Status.NEW: 0>>]
[0xd1ca:1] Discovering endpoint information
[0xd1ca:1] Endpoint descriptor already queried
[0xd1ca:2] Discovering endpoint information
Tries remaining: 3
[0xd1ca] Extending timeout for 0x42 request
Tries remaining: 2
[0xd1ca] Extending timeout for 0x43 request
Tries remaining: 1
[0xd1ca] Extending timeout for 0x44 request
Tries remaining: 2
[0xd1ca] Already have endpoints: {0: <zigpy.zdo.ZDO object at 0x7fa1f83e50>, 1: <Endpoint id=1 in=[basic:0x0000, identify:0x0003, ota:0x0019, multistate_input:0x0012] out=[basic:0x0000, groups:0x0004, identify:0x0003, scenes:0x0005, ota:0x0019, multistate_input:0x0012] status=<Status.ZDO_INIT: 1>>, 2: <Endpoint id=2 in=[] out=[] status=<Status.NEW: 0>>, 3: <Endpoint id=3 in=[] out=[] status=<Status.NEW: 0>>}
[0xd1ca] Initializing endpoints [<Endpoint id=1 in=[basic:0x0000, identify:0x0003, ota:0x0019, multistate_input:0x0012] out=[basic:0x0000, groups:0x0004, identify:0x0003, scenes:0x0005, ota:0x0019, multistate_input:0x0012] status=<Status.ZDO_INIT: 1>>, <Endpoint id=2 in=[] out=[] status=<Status.NEW: 0>>, <Endpoint id=3 in=[] out=[] status=<Status.NEW: 0>>]
[0xd1ca:1] Discovering endpoint information
[0xd1ca:1] Endpoint descriptor already queried
[0xd1ca:2] Discovering endpoint information
Tries remaining: 3
[0xd1ca] Extending timeout for 0x45 request
Tries remaining: 2
[0xd1ca] Extending timeout for 0x46 request
Tries remaining: 1
[0xd1ca] Extending timeout for 0x47 request
Tries remaining: 1
[0xd1ca] Already have endpoints: {0: <zigpy.zdo.ZDO object at 0x7fa1f83e50>, 1: <Endpoint id=1 in=[basic:0x0000, identify:0x0003, ota:0x0019, multistate_input:0x0012] out=[basic:0x0000, groups:0x0004, identify:0x0003, scenes:0x0005, ota:0x0019, multistate_input:0x0012] status=<Status.ZDO_INIT: 1>>, 2: <Endpoint id=2 in=[] out=[] status=<Status.NEW: 0>>, 3: <Endpoint id=3 in=[] out=[] status=<Status.NEW: 0>>}
[0xd1ca] Initializing endpoints [<Endpoint id=1 in=[basic:0x0000, identify:0x0003, ota:0x0019, multistate_input:0x0012] out=[basic:0x0000, groups:0x0004, identify:0x0003, scenes:0x0005, ota:0x0019, multistate_input:0x0012] status=<Status.ZDO_INIT: 1>>, <Endpoint id=2 in=[] out=[] status=<Status.NEW: 0>>, <Endpoint id=3 in=[] out=[] status=<Status.NEW: 0>>]
[0xd1ca:1] Discovering endpoint information
[0xd1ca:1] Endpoint descriptor already queried
[0xd1ca:2] Discovering endpoint information
Tries remaining: 3
[0xd1ca] Extending timeout for 0x48 request