Unable to connect SMA inverter

I have a SUNNY BOY 3.0 connected to my network and am able to reach it over http using the IP address. This is my config which produces nothing but ‘unknown’ values for all sensors:

- platform: sma
  ssl: false
  verify_ssl: true
  scan_interval: 120
  password: !secret sma_pass
    - current_consumption
    - total_consumption
    - pv_power
    - total_yield

If I set ssl to false and verify_ssl to false I get

ERROR (MainThread) [pysma] Could not start session, 404, got {}

If I set ssl to false and verify_ssl to true I get

Could not start session, Could not connect to SMA at (timeout), got {}

What else could I try in order to get readings from this device?

Please read and implement How to help us help you - or How to ask a good question

Still not good enough?

Did you ever find a solution to this?

I might have figured something out. After moving homeassistant from one host to another, it had changed its IP from to

After that i added the SMA inverter to my fresh installation of homeassistant. Everything was working fine and my SMA Inverter was responding to requests from

Once hassio had been fully restored/installed (and the old host had been phased out) i changed the IP to what i had once intended it to be: From that point onwards the connection between Hassio and my SMA suddenly stopped working.

I was able to ping the SMA Inverter from hassio, but when i tried to wget the web-address of my SMA Inverter, i received no response at all. I figured that the inverter somehow blacklisted that IP, so i tried to change it.

The connection to the SMA inverter was re-established once i manually changed the IP (of hassio) to litterally something else, in this case:

Then i tried something funky: change the IP of my workstation to the IP that was once hassio’s, and guess what? i wasn’t able to reach the SMA from my workstation.

I dont know what is going on here, the SMA Inverter somehow refuses to respond to hosts with the static ip that was once hassio’s. My guess is that SMA blocks requests from what it thinks is it’s DNS server? So it might have something to do with pi-hole or AdGuard.

Try changing the IP of hassio, i think the SMA Inverter is blocking the DNS server from connecting to it.


I just removed adguard from hassio, removed the adguard-dns entry from my router and i’m able to connect to the SMA inverter again. This seems to support my theory.

1 Like

I added the device using the new integration. Then ticked SSL, which is weird, because this is a non-secure local IP and whaddayaknow: it worked. It did not work without SSL checkbox.