Unable to connect to HA at home from mobile app or browser

I’ve got a seemingly very odd problem.

I can’t connect (via IP or mDNS) to my HA server on my internal network from two Pixel 7 Pro phones. Using the exact same wireless network, my laptop connects just fine. Initially I thought this was an app issue, but I’ve tried from both Chrome and Brave mobile browsers and neither connect.

I have no firewall rules on the phones, nor on the network. What could be causing this?

What error are you getting in the browser?

Address unreachable.

It makes no sense. Rebototed phone, running latest patch of latest Android OS.

Open terminal from android and ping DNS or IP,

http or https?

with wifi can you open the modem page from android? example or

I can’t ping HA, but it doesn’t reply from my laptop either, so I assume HAOS has ICMP disabled.

Only using http.

And yes, I can connect to the router web page, as well as my local Unraid server.

Your HA on internet or intranet?
can you give me the link without password to try?

I have Nabu setup, yes. And while I appreciate the offer, I’d rather not. It works fine from Nabu (except from my phone on internal wifi).

Since its happening on two Android phones, but not my Windows laptop, on the same wifi network, it has to be some Android issue I’d think. But I have no idea what that might be.

@dshokouhi While this clearly isn’t your problem, do you have any ideas why this could be happening?

Do you get the “cannot connect” pop-up in the android app? or are you seeing a general HA frontend error?

From the app we should look at the Companion App logs

Yes, I get a can’t connect, with an option to try the other URL - neither internal nor external work though.

Not sure if you read everything though, I can’t connect from a web browser either. I get ERR_ADDRESS_UNREACHABLE.

I did read everything and I am still waiting on the logs I mentioned in my response, it will show us why its failing and give possible clues to the issue.

The fact that it does not work in a browser suggests another issue maybe proxy related or even certificate related but the companion app logs will tell us why it failed and what IP address from where it tried to reach instead of the generic message above.

The main thing is you need to fix the issue occurring in the browser on the same device so that the app can work.

I had a similar problem because the ssl certificate was incorrect (chiper suite) and also with the reverse proxy configuration, same problem but I still don’t understand if yours is on the internet or intranet (mDNS ??) bye

And yeah, I totally get that once I fix the issue in the browser, the HA app will work just fine. Thanks for taking a look.

@sdavides My HA server is available over the internet through Nabu. However, when I’m at home, I use the internal IP.

03-02 13:21:13.696 19120 19120 E WebViewPresenterImpl: Unable to retrieve external auth
03-02 13:21:13.696 19120 19120 E WebViewPresenterImpl: java.net.ConnectException: Failed to connect to /

so this is actual failure are you certain the IP is correct? have you check the URL saved by the app in Companion App settings to confirm its correct?

I don’t understand you, you say you use Nabu, (i don’t know nabu ) but do you have a local ip address at home? However cancel Nabu, use a cloud server service (which costs less) with homeassistant supervisor or put a server at home and expose it on the internet from the modem.

Nabu Casa is the only official cloud service for Home Assistant :wink:

If the user experienced teh same issue as you did the app would actually notify that SSL is invalid. In this case it looks like maybe an incorrect IP address is used or something with network routing, possibly DNS related but still not something the app can solve.

Why use nabu if you can expose your HA with a simple rule on the modem?

because its not that simple for most people and has benefits for making certain other features easier to use and setup like Google Assistant or Alexa.

Nailed it!

I ended up doing a restore about a week ago thanks to an Unraid bug I didn’t know about. Seems the restore doesn’t keep static assignments! My laptop worked because I was using mDNS. No idea why my phone wouldn’t work with mDNS, but no matter - its fixed now.


1 Like

I don’t need to use Nabu at all. I use it as a way to help pay for the ecosystem that I love.

1 Like