Unable to connect to Home Assistant - certificate error

The app doesn’t open and the Google Chrome Browser say Deceptive site ahead within a red page. Nothing works to fix the certificate problem. The thing is that with other browsers there is no certificate error but the main problem is that the android app doesn’t open because of the same error. Deceptive site ahead

1 Like

That is the probably chrome browser’s malware detection that kicks in.
You need to contact Google about it or use another browser.
I can recommend Firefox. It has more privacy.

Yes I’ve changed my browser on computer but t

he Home Assistant crushed to because of this.

Thank you Francis! I guess the solution is to report to google that this is not a phishing site.

1 Like

same issue starting today, any help please.

I commented just above you what the solution is

I Just restarted HA, everything was fine.

+1 solved with the nginx add-on reboot


Same problem, nothing worked. I have SSL renew minutes ago. I had a custom certificate which was about to expire but it was not expired.
I checked

  • The certificate on local computer the date is fine will expire in June now
  • Time date and time-zone
  • I cleared cache on mobile app
  • I cleared storage on mobile app and configured again
  • Access from browser on same device works without issues
  • Reboot the entire system
  • I removed local url from mobile device
  • Set the local url same as public url

Nothing worked;
For me it appears only once, when I open the app, if I’m just doing a touch outside of the dialog never appears again.
So, trying to isolate the issue I created another dashboard without too many tiles just some simple things in there and set that dashboard as the default for mobile app.
Surprise, it works fine. When I’m loading my initial dashboard, the dialog appears again.
So, as a conclusion, it seems (at least for me) that is not my certificate that fails but most probably I have a link, in the dashboard, which is not quite secured.
I will investigate all the links from that dashboard to find it but most probably I would have to go and check all the tabs from that dashboard and not just the first one :frowning:
Hope it helps.

Back… YES found it. It was just an URL which was loading an image as background for a tile, and that URL had an expired certificate. Removing the URL fixed the problem. Would be nice if those faulty URLs would appear as warning in logs.


They can’t be in the logs because the server does not see the certificates.
It is the client that makes the connection and get the faulty certificate.

I’m aware about that. I was referring to developer tools console. I’m a back-end dev, I don’t exactly know how front-end is doing a request and if is possible to check that in front-end but if the browser knows when an url has an expired certificate… it should be a way to do that … maybe something like this???

Well, you should be able to make a sensor that check the certificate and extract the expire date, since it is public information in the certificate.
It is just not something HA do by default.

Thank you, I had similar problem and couldn’t figure it out! : )
I have rain map service on one tile and seems like their certificate has got old!

nginx addon restart solved it for me too - thank you for suggesting.
HA reboot didn’t help.

this solved for me thanks!!!

I’ve received the following error several times over the past year. Simply restarting my raspberry pi device solves the issue:

“Unable to connect to home assistant: The date of the home assistant certificate is invalid, please review the home assistant certificate or the connection settings and try again.”

Before moving to duckdns and lets encrypt crap, all my device used to connect flawlessly. Now only my laptop and iphone connect, none of android phone in our family is able to connect. It is frustrating to deal with something that shouldn’t be there and none has clue why this is happening so we can avoid this situation.
Perhaps I am better off using HA in local and find out wireguard route to connect from outside. Previous attempt has not been successful integrate wireguard in HA though I have integrated lots of Ubuntu, raspberry pi with wireguard.

I believe it is the DuckDNS certificate. Even though the date shows that it shouldnt be expired, it is confused (ie essentially expired). Delete the certificates. Delete DuckDNS. Delete NGinx. Reboot locally. Re add nginx. Readd duck dns. Reboot. Should work.