Unable to connect to Home Assistant - certificate error

I am getting an error while trying to connect to HA through my DuckDNS link. Through the browser I just get: Unable to connect to Home Assistant.
But in the Android app I see something like: The date of the HA certificate is invalid.
But I also received an error earlier which stated something about the SSL handshake.

What can I do to fix this?

Certificates are only valid for a limited time and when the expire date is reached then you get errors like that.
Let’s Encrypt certificates is recommended to be updated each 30 days and only last 60 or 90 days.
Other providers have certificates with longer validity periods, like 1 or 2 years, but these usually have to be paid for.

Sure, I forgot to add this information.
I have installed the DuckDNS add-on with a Let’s Encrypt certificate. The DuckDNS add-on shows no errors at all. It shows OK and NOCHANGE and all is green.
So where could the error be coming from???

Is the date and time correct on the machine you are trying to connect from?

Thanks for your reply. Yes, they are correct.
However, after a restart the problem was solved :sweat_smile:


I have the same issue, tried to restart Home Assistant but issue still there.
I have been using app on IOS to connect using DUCKdns for almost 3 months with no issues and suddenly now the problem appeared.

How to solve it? Is there any way to update SSL certificates so they match with the updated ones of duckdns?

Sounds like you have a certificate that has not been renewed.
In the browser you can see the certificate that the server presents and you will usually also get an error message with why the certificate is rejected.
If it is expired, then look a your certificate service setup.

Hi everyone, I apologize for coming to this party so late, but… I got the SSL Certificate error today after upgrading to 8.5 - I’m using NabuCasa to connect remotely and I’m in EU right now so I can’t get to my server.
Who manages the SSL Cert that is issued to HA ? With all the upgrades, I would think that a new cert would be submitted as part of the install.

Should I contact Nabucasa for this issue ?

It is probably the certificate at NabuCasa that is causing the problems, but the problem might arise from your computer.
Check your date, time and especially timezone.
These things must often not be more than 5 apart from the same values on the server, so forgetting to set the timezone, but changing the date and/or time will bring your out of sync.

I have the same problem. My cert expires in April. I forced the renewal. I have no errors but I can’t login with my duckdns address with companion app

Any Ideas?

1 Like

Make sure that the file patch are correct, then see if a restart of the host (not just the HA core) solves it.

I got same problem last night. DuckDNS insisted cert no need renew but HA app and my chrome said it had expired already.
I tried solutions here try to renew it by force, but none of them worked for me(maybe I did not understand correctly).

Then I changed to another domain name, restart duckdns, got new cert, and update the domain name in nginx as well, then it works.

I guess this bug will last for a while, so prepare 2 domains sounds not a bad workaround.

I have the same issue today “unable to connect to Home Assistant- certificate error”

But my certificate is good.
I’m using Duckdns and Nginx.
First I tried simple system restart —> no solution
only duckdns addon restart —> no solution
nginx addon restart —> good solution!

So only the nginx addon restart was the right solution for me.


Simple system restart?
There is no such thing.
There is a HA core restart and a host reboot.
HA core restart will only restart HA core and no addons.
Host reboot will restart the entire machine with both HA and all its addons.

Sorry, I mean developer tools/check and restart —> restart
I thought that restarts the addons too, but that didn’t solve my problem.

No that only restart the core.

The other is Settings → System → Hardware → 3 dots in upper right corner.

1 Like

Ok I see. Thank you Wally for the important clarification!

I’m using Duckdns and Nginx. i restarted everything, individual and general. nothing works. my certificate is still valid thil may.

Not exactly descriptive!
When does it fail in the process and how and with what error messages?
What does the logs of the integrations tell you?