Unable to connect to Home Assistant externally

I have my HomeAssistant setup via DuckDNS so I can access it internally as well as externally and it all works fine.

After a power cut yesterday though the external access has stopped working (internal still OK) and I just get this message :-

I’ve forced an update of DuckDNS to make sure it’s using the correct external IP but that made no difference. It seems like an external connection must get some of the way in to display the HA logo but I cannot see anything in the logs to indicate what might be going on.

Any suggestions or troubleshooting tips?

Is there any error logs showing up? Have you add this in configuration.yaml?

  use_x_forwarded_for: true

I can’t see anything in Logbook or Configuration > Logs but if there is anywhere else I can check then please let me know.

I don’t have that code in my configuration.yaml but it’s always worked fine until yesterday.

You need to add that line to enable local proxy. It is the breaking changes for Core 2021.7. Try adding that line first and restart HA.

As a reference, you can read this.

I will look into that but I think the main issue is that my POS router from Sky has defaulted and lost all of my LAN-side reservations :exploding_head:

Guess that’s my Sunday morning sorted then!

Thanks for the quick reply.

If it’s your provider’s router it could be that they made an FW upgrade. If so, it will happen again. That’s how my (ex) provider worked: at each upgrade they just defaulted my router, no warnings, no notifications…
Now at another provider that box is only modem, rest of the job is in my own router.