Unable to connect to Razberry on Pi3

I have a raspberry Pi 3 running the latest version of Rasbian light running HASS IO supervised in docker containers and new Razberry. I am unable to connect to the Razberry using the zwave2mqtt add on. I was able to get to work once but have not been able to reproduce my steps after dabbling with Zway.

From a fresh install of Rasbian Lite here is what I have done.
Enable SSH

Add the following parameters to the bottom of the sudo nano /boot/config.txt file.



Install Docker on Pi


sudo apt-get update && sudo apt-get upgrade -y
sudo apt-get install network-manager apparmor-utils jq -y
sudo reboot
curl -fsSL https://get.docker.com -o get-docker.sh
sudo sh ./get-docker.sh
sudo usermod -aG docker {username}
sudo chmod 666 /var/run/docker.sock
sudo apt-get update && sudo apt-get upgrade -y

Disable hciuart

sudo systemctl disable hciuart


Install HASS in a Container


sudo curl -Lo installer.sh https://raw.githubusercontent.com/home-assistant/supervised-installer/master/installer.sh
sudo bash installer.sh --machine raspberrypi3

Attach Razberry to Pi

Install Z-WaveJS2MQTT Add On

Point Add On to /dev/tty/AMA0

and click save

At this point i get the follow the error:
INFO ZWAVE: Controller status: Driver: Failed to initialize the driver: Timeout while waiting for an ACK from the controller

Any advice on what setting I may still be missing or incorrectly using?

Is this the actual path you are using, or did you type it incorrectly in your post? /tty/AMC0 is not valid at all. USB sticks use /dev/ttyACM0. A Razberry would use /dev/ttyAMA0 because it’s connect to the GPIO. In either case, you should be using the /dev/serial/by-id path, if it exists.

Typo on my part. I corrected my original post with a screen shot of the options available. I tried the ttys0 option but that did not work either.

Maybe the instructions on this post help?

Still no luck. Following those steps only causes the deprecated version of openzwave integration to be installed. Which by the way works just fine. It seems like something is just broken in Z Wave JS regarding Razberries.