Unable to connect to Wifi on ODroid N2+

Hi there,

I migrated my HASSOS install from a raspberry pi 4 to an Odroid N2+. I figured I’d use the same hardware as Home Assistant Blue, since that would be well supported. Installation went fine and restoring my Pi4 backup to the Odroid went without problems. All with a wired network connection.

Then came the moment I wanted to enable Wifi. So I bought the Odroid 5A wifi module. AFAIK the procedure is to navigate to Supervisor → System and click the ‘Change’ link next to the IP address and there’s a new WLAN tabpage. I can scan for wifi access points, choose the correct one (Deco M9 Mesh), enter the credentials, click save and then… nothing, no IP address and no activity in my routers DHCP table. After a reboot the settings are gone and no dhcp query had been seen bij mij dhcp server.

I’ve also tried: using my phone as wifi access point (in case mesh wifi was the problem) and connecting to wifi using Home Assistant CLI (using network update). Both attempts failed.

I don’t see anything wrong in the logs, but I’m not sure which logs I should be checking.

Can anybody help me troubleshoot?

I see the sane thing on my pi4. I have given up using WiFi on that machine.

I’ve never had problems with my Pi 4 wifi.

I don’t either, as long as I use straight debian, dietpi or raspberry os. As soon as that pesky networkmanager gets involved ( supervised or HA OS), it does not work anymore.

Since I feel that it should work the way I’m trying to use it and I’m using the ‘gold standard’ in hardware for running Home Assistant, I’ve filed a bug report: https://github.com/home-assistant/core/issues/56452