Unable to connect via browser

Hi All,

Installed HA today on RPi5, tried to connect via various browsers on windows.



Tried reinstalling HA, and installing on a different microsd.

Could not connect.

I have a Plusnet Hub 2 router (a UK ISP), is this something to do with router settings? I’m lost as to what to do next. TIA

ETA: Further googling suggests something about mDNS? Could this be a router setting that I need to change?

ETA: I’ve purchased new microSD cards, working on the assumption that both cards I used are corrupt/not good enough. Doesn’t feel like the issue but it’s all I got :frowning:

I will try again with the new microSD cards, in the meantime thanks to all who responded, looking forward to more ideas in the morning! Goodnight.

I don’t use an RPI for HA but i would recommend connecting a monitor to the rpi to see if there are any errors or a clue.

1 Like

Thank you for your response.

I did do that, the HAOS seems to be working fine. The desktop boots normally albeit a bit slow.

The issue has made me want to get a HA green, but if the issue is the router settings then I’d have to resolve that first anyway.

Are you certain the Ip address is correct?

1 Like

Im certain. I connected a screen to the RPi, and hovering over the network icon top left shows the ethernet IP which is x.x.x.124 and the wlan IP which is x.x.x.126

Tried both.

Is the station you tried from have the same network mask, and also has the x.x.x.# as the RPI?
Are you able to ping the RPI at the address?

1 Like

Just tried this. Yes the laptop pings the RPi address and gets a response. Both are 192.168.1.x

Your browser is not trying to connect through httpS instead of http?
What does your browser return?
Are you using browser add-ons?
Did you try with a private session?

If you are sure about the IP address, you should keep trying with that.

1 Like

Firefox: can’t establish a connection to the server at
Edge: refused to connect
Chrome: refused to connect

I made sure VPN is off.

Have disabled all extensions.

Same errors in private browsing modes.

What if you try the WLAN IP?
Did you try with the same system all the time and can you use another system as a test?

Doesn’t the RPi with HAOS output a console/text screen with the statistics?
How can you hover over an icon?

To my knowledge, you should see something like this:

My HAOS has a graphical desktop with a background picture of a fisherman fishing with ducks.

I tried the WLAN IP address in all above tests as well.

Can you elaborate a little on how you installed HA, which installation method you have chosen?

I used Raspberry Pi Imager v1.8.5.

Choose Device: Raspberry Pi 5
Choose OS: Rasp…


BRB going to try a thing…

Could it be that you have installed Raspbian/Raspberry OS instead of HA?


I’m both embarrassed and elated. The fisherman with the ducks should have been my clue.

Thanks for guiding me through this @Nick4 and @pcwii

Hopefully this ordeal will bring comedy to some people. I’m sure I’ll be back again with something like this in the future.


So, you will be following these instructions? :slightly_smiling_face:

1 Like

I’ll try but can’t promise, as you can tell from today’s adventure.

Didn’t slow down and rtfm. Thanks again.

1 Like

Good luck with installing HA :innocent:
But that should be a breeze with the link that @MaxK provided!