Unable to create Date and/or time helper

Hi guys i’ve been trying to setup a input_datetime helper but it is greyed out in the UI menu.
i know i need the default_config: in my configuration.yaml file which has always been there so then i added input_datetime: in my config file also but it’s still greyed out and i’m getting the following error when rebooting…

Logger: homeassistant.setup
Source: components/input_datetime/__init__.py:217
First occurred: 22:25:35 (1 occurrences)
Last logged: 22:25:35

Error during setup of component input_datetime
Traceback (most recent call last):
  File "/usr/src/homeassistant/homeassistant/setup.py", line 255, in _async_setup_component
    result = await task
  File "/usr/src/homeassistant/homeassistant/components/input_datetime/__init__.py", line 125, in async_setup
    await yaml_collection.async_load(
  File "/usr/src/homeassistant/homeassistant/helpers/collection.py", line 184, in async_load
    await self.notify_changes(change_sets)
  File "/usr/src/homeassistant/homeassistant/helpers/collection.py", line 141, in notify_changes
    await asyncio.gather(
  File "/usr/src/homeassistant/homeassistant/helpers/collection.py", line 370, in _collection_changed
    for entity in await asyncio.gather(
  File "/usr/src/homeassistant/homeassistant/helpers/collection.py", line 336, in _add_entity
    entities[change_set.item_id] = create_entity(change_set.item)
  File "/usr/src/homeassistant/homeassistant/components/input_datetime/__init__.py", line 234, in from_yaml
    input_dt = cls(config)
  File "/usr/src/homeassistant/homeassistant/components/input_datetime/__init__.py", line 217, in __init__
    current_datetime = py_datetime.datetime.combine(
TypeError: combine() argument 2 must be datetime.time, not None

These errors are because i’ve added a input_datetime: into a package yaml file.
I’ve since read i may have a old file in my .storage folder causing a conflict but i can’t see anything in there.
Has anyone any ideas i could try


If you are not using default_config then, minimally, input_datetime: needs to be included in configuration.yaml (and Home Assistant restarted in order to detect the changes) so that the associated Helper becomes accessible.

If that fails to fix it then there might be some sort of confusion involving the reference to input_datetime in the package. Try running it without the package and see if that improves anything.

Thanks for the help i’ve just cut out the input_datetime: section from the package file and pasted directly into the configuration.yaml file but it’s still the same after restarting unfortunately.
I’m at a total loss with it as it should be working.

Why not just put default_config: back into configuration.yaml? Or is that still there also?

(Sorry, it’s getting hard to track what is/isn’t present)

Yeah I’ve put it back in as loads of things stopped loading when I took it out.
So now when it boots I’m getting the same error for default_config and input_datetime