Unable to delete devices even after z-wave remove node - getting duplicate device

Tags: #<Tag:0x00007f738e024578>

I have some z-wave devices that I cannot remove. I have marked them as failed: true in status. I have unpaired them and yet they remain in the devices database. I have an unknown device 5 that is not on the Aeon z-stick, but just persists in HA devices and just shows in z-wave integration as iniitializing. I also have a Wallmote Quad that we gracefully removed from z-wave, but the device stays in the database. It was showing as node 12 and that is not in the z-wave nodes, but persists in the HA devices list. The node was added back and is now node 13 and it just shows as a duplicate in devices.

It would be nice if HA team focused on stability rather than new features for a change. The z-wave interface is flaky and removing nodes is problematic at best. I’ve also tried forcibly removing the device from zwcfg as well. They are not in the z-stick, not in the zwcfg, but still remain in the devices list and no way of deleting them in Lovelace.

It’s frustrating at best. Any help would really be appreciated to remove devices that don’t exist :frowning:

1 Like

If you removed the nodes prior to 0.102 you need to manually delete them from the .storage/core.device_registry file. 0.102 fixes the need to do that.

1 Like

Thanks for getting back to me. The Wallmote was removed in 0.102.1 version and didn’t delete from the interface. I’ll check the .storage file.

I have the same problem. I am running 0.103.0 and remove failed node doesnt work, resulting in

2019-12-14 14:01:00.502 Warning, contrlr, WARNING: Received reply to FUNC_ID_ZW_REMOVE_FAILED_NODE_ID - Node not found

Cleaning out .storage/core.* doesnt help either, since on reboot the device and its entities are re-added into core.*

Whats left?

I remove them from .storage and the devices and they return. I’m still stuck on this as well

1 Like

Did you stop Home Assistant before editing the file?

Personally, I work on copies, and compare with kdiff3 a few million times before over-writing. In this case though, I think I might have missed the entry for the zwave entitiy itself.

I was filtering on 29-XXXX of unique_id when stripping, and forgot the unique_id of Node-29…

So after the four attempt, it finally seems to be gone.

I’ll take that back. Now my node 29 is back, and the next one which failed, cant be removed either. I really feel that the device management **** ****.

I’m experiencing the same issue with a couple Z-Wave devices (Honeywell Thermostat and a Neo Coolcam wall switch).

I had to remove and re-add them a couple of times and now have multiple duplicate entries for each.

I’m not sure if it makes any difference but I’m using the secure join on these devices.

I had to re-add a couple Z-Wave (not plus) devices and those did not duplicate.

I’m running:
HA 0.103.5
Hass.io supervisor 193
HassOS 3.7
Z-Wave: Razpberry 2 configured via configuration.yaml

1 Like

Hi all – anyone get any further with this?

I have exactly the same issue… Multiple instances of z-wave devices, even after removing node, removing all entities etc. They no longer show under z-wave at all (nodes gone) but the entityless devices are strewn across HA.

I had to manually remove per this post:

What I have tried up until now to delete a dead z-wave device/entity:

  1. grep entire ha config folder for deviceID and entityID
  2. delete the entries found in .storage/core.device_registry and .storage/core.entity_registry
  3. delete home-assistant_v2.db

And still the device is magically there :frowning_face:
I’m currently migrating from Domoticz and I can’t remove the z-wave integration every time there a problem when I have z-wave 30+ devices…

(ha version 0.114.4 running in docker)

I’m having the same issue - super annoying with dead devices that’s sitting in the “initializing” for ever.

Anyone know if there is a issue for this over at GitHub? I’m seeing the same thing. I removed a couple of dead nodes and they no longer show in entities, but still show up in Devices under Zwave (in my case OpenZwaveBeta). Using ozw-admin they are definitely gone from qt-openzwave so they are stuck in HA somewhere.

I have the same issue and even after removing from .storage/core.device_registry the devices still appear

I have the same issue and think the only way I’m going to be able to resolve this is a clean install. Should I be removing all the Z Wave devices that do work first? Or can I just do a clean Hassio install and re-adopt them after that?