Unable to delete helper

Hi there.
I am unable to delete multiple helpers from my HA instance. I dont want them to show up anywhere. Delete everything. In best case every old event stored in the database. These currently show up in “Dev Tools” → “States”, but not in → “Statistics” I get the message “This entity (‘input_boolean.biomull_notify’) does not have a unique ID, therefore its settings cannot be managed from the UI” (I have 4 entities that do that)

I also have one entity that doesnt show in either “States” nor “Statistics”. It has a red symbol (exclamation mark) in the “Settings” → “Devices and Entities” → “Helpers” list. I am not able to access any settings of said helper

I would like to avoid editing the DB itself manually because of the obvious risks. I already tried using the Recorder PURGE_ENTITIES service. Didn’t work. Tried this:

service: recorder.purge_entities
target:
  entity_id: input_boolean.biomull_notify

did you try purging the recorder?

set the days to 0

image

I’ve got the same issue with 7 helpers.

How do I prevent the purge from deleting everything and why exactly would “days: 0” help?

Try going directly to the page using:

http://homeassistant.local:8123/config/helpers

and delete the helper from there.

I apologize, I miss understood you and thought you were just seeing remnants of the helper. I didn’t realize they were still appearing on the helper entity page.

click settings

hit delete

Let me know if that works

Entities in the states list are aggressively cached in the browser (and companion app). It’s likely you’ve already deleted them but they’re just stuck in your browser’s cache. Clear the cache, or if you’re not sure how to do that (or aren’t sure you did it properly) open an incognito window in your browser and log into your home assistant instance. My guess is you won’t find those entities.

That was my second suggested step, thank you!

They’re stating they are in the entities list so that means they haven’t been deleted (IMO) from HA.

Amazing how much HA data is stored in your browser cache. Without frontend reloads and cache clearing you may think a change never took effect.

Sorry for the late reply on the topic was quite busy the last few days…
When going directly to http://homeassistant.local:8123/config/helpers the “biomüll_notify” is actually gone. thats goot to see.
For the helper with the red exclamation point i cant say the same. it still shows. even in incognito. when clicking the helper I get this view:
image
notice how I am not able to cick on the cog icon you see on yours. when i click on any other helper i also see that icon.

That is odd, let me look into that. Thanks for the follow up and images!

Do you have an adblocker running on your browser?

1 Like

Even though this is a rather old post, I’ll put this here. I encountered about the same problem as indicated above (not being able to delete a helper, not even being able to change it’s settings). With the help of this “reminder” for adblockers I found out that disabling “PrivacyBadger” and “Ghostery” in Google Chrome did the trick.

Upon “trusting” the Home Assistant url and refreshing the page all options of helpers and the delete button re-appeared. I forgot how aggresive these addons can act…

1 Like

Having the same problem. I need to delete some helpers that i created for testning, and i also want to change the settings for some. But none of this is possible when i click the gear icon up to the right. The page it forwards me to is all blank.
Might work in a browser, but it must work in the app?

Try entering the helper address directly in your browser like this

image

That was the method I used to circumvent the blank page.