Unable to detect Tuya Luminance Sensor


I’ve followed all the steps to integrated my Tuya devices with the new Tuya integration, and it worked for all of my devices, except the Tuya Luminance Sensor (ldcg). Although it appears in the Tuya IoT Platform website as online and in the debug tab shows that it receives data, it doesn’t appear inside the HA either as a device or an entity. I see there only the rest of my devices.

Any ideas?
I appreciate any help you can provide.

This is the sensor:

System Health

version core-2021.10.5
installation_type Home Assistant OS
dev false
hassio true
docker true
user root
virtualenv false
python_version 3.9.7
os_name Linux
os_version 5.10.17-v8
arch aarch64
timezone Europe/Athens
Home Assistant Community Store
GitHub API ok
Github API Calls Remaining 4958
Installed Version 1.15.2
Stage running
Available Repositories 945
Installed Repositories 7
Home Assistant Cloud
logged_in false
can_reach_cert_server ok
can_reach_cloud_auth ok
can_reach_cloud ok
Home Assistant Supervisor
host_os Home Assistant OS 6.5
update_channel stable
supervisor_version supervisor-2021.10.0
docker_version 20.10.7
disk_total 57.8 GB
disk_used 38.1 GB
healthy true
supported true
board rpi4-64
supervisor_api ok
version_api ok
installed_addons File editor (5.3.3), Mosquitto broker (6.0.1), FTP (4.2.1), Node-RED (10.0.1), TasmoAdmin (0.15.0), Grafana (7.2.0), InfluxDB (4.2.1), Check Home Assistant configuration (3.9.0), Duck DNS (1.14.0), Home Assistant Google Drive Backup (0.105.2), Terminal & SSH (9.2.1), MariaDB (2.4.0), Visual Studio Code (3.6.2), eWeLink Smart Home (1.2.2)
dashboards 2
resources 0
views 1
mode storage

I reply to myself because the problem was solved by itself when I’ve updated to core-2021.11.1