Unable to fetch auth providers

HI guys,

I seem to got myself into a small pickle. My HA server is running fine in a VM on Ubuntu on my main desktop machine which thus needs to be left on all the time.

Just bought a cheap Celeron NUC to dedicate entirely to HA. Installed HAOS on the machine and wrote the HAOS image as per this article without too much trouble and booted into the new instance of HA… All good.

I then took a full backup of my running system saved to my Qnap NAS drive which is set up as a remote backup location for HA. Configured the same backup location for the new instance and restored the full backup. Shut down my old version while the backup was restoring - and the new one opened at the URL of the old one just as I was hoping.

However, I can’t log in, because I’m told…

Unable to fetch auth providers. http://192.168.1.xxx:8123/?auth_callback=1

It never asks for my log in credentials so I can’t get to the GUI to change anything.

I’ve been on this for hours now and I’m about to collapse - so I’ll shut down the new one, restart the old one, and come back again tomorrow evening.

Any pointers where / how to bypass whatever the new instance is complaining about so I can regain control?

Many thanks in anticipation,


In configuration.yaml comment out anything under http:

Thanks for the tip Habitat Tech.

Unfortunately it hasn’t got me over the line. I accessed configuration.yaml and commented out the only http line in the file (intended to trigger an IP update on my DDNS server), but after I saved that change I couldn’t get the system to boot at all. :frowning:

So I nuked the file system and did a fresh install from scratch. This time, I changed the DDNS line in config on the running system, and switched off MFA login (just in case) and took a new backup to restore from.

The fresh install booted OK and offered the option to upload a restore file - which I did. All seemed to work OK, but at a random DHCP assigned address. All my IOT modules are set to communicate only with the fixed local IP so there were a lot of issues that were asking to be fixed.

Because I couldn’t remember how I had set the fixed IP in the CLI originally, I just went to my router and told it to assign this instance the required IP address on every boot. Rebooted the machine, and got the exact same error at login:

“Unable to fetch auth providers. http://192.168.1.xxx:8123/?auth_callback=1
Have no opportunity to log into the GUI at all.
This time there are no http lines in configuration.yaml so that can’t be the issue.

Any other clues?

My suggestion is to avoid using DDNS with HA, as it just complicates things unnecessarily. Instead use Zerotier or Tailscale (my personal preference is Zerotier).

You can then access HA remotely using the Zerotier IP address.

It is very easy to install. Create a free Zerotier account and network. Install the HA Zerotier addon and specify the network address. Start the addon and then go to your Zerotier account to authorise the HA host. That’s it; from then on you can access HA from any location on the planet which has Internet access.

To assign a fixed IP address to your HA: Settings → System → Network → IPv4 → Static.

Remember to remove the MAC reservation on your router, or if you decide to leave it do not make network changes to HA (leave as dynamic).

I had deleted all the DDNS settings anyway without fixing the issue.

So I gave up in the end and set the NUC instance to a different ip address, and manually went through all my IOT device configurations and changed all the ip settings to communicate with the NUC.

This does mean that the NUC version which I last played with yesterday is missing all the history data that the VM version has accumulated in the last 24 hours since the backup that the NUC was restored from. I will have to try to get a partial backup that is granular enough to pick up only the sensor history in the relevant 24 hour period to restore into the NUC instance… [fingers crossed]