Unable to find component google_assistant(Solved)

I’m trying to setup google assistant with my Home Assistant, and I’ve been following this https://home-assistant.io/components/google_assistant/, I’ve come to the point where I think that the google side works, I can see my project in the Google Assistant app, as: ‘[test] your app name’, when I select it, it just gives HTTP code 404.

Which i related to the log from homeassistant:

2018-01-12 16:49:50 ERROR (MainThread) [homeassistant.loader] Unable to find component google_assistant
2018-01-12 16:49:50 ERROR (MainThread) [homeassistant.setup] Setup failed for google_assistant: Component not found.

I’ve been trying to search for other posts with similar problems but without luck… :frowning:

Can anyone help me in the right direction?

What version of Home Assistant are you running?

Google Assistant component was “Introduced in release: 0.56”

Just updated to the last version suggested on my frontend by ‘updater:’
but when looking in the ‘about’ section to the left it says 0.48.1.

You will need to fully update your system to take advantage of Google Assistant. There were LOTS of changes since .48, so you might want to research that before you dive in. There were some syntax changes in the configuration.

When working with components, make sure you have a version that supports them. On every component you should see something similar to this section in the upper right hand corner.


Well isn’t a update done like this: ‘$ pip3 install --upgrade homeassistant’ ?

I believe so, but I do not use the self-installed any more. I use docker.

One thing to note is that recently, there were requirements for a newer version of python, so again, you need to research the upgrade path that you will require. It might make sense to make a fresh install and copy over your configuration directory, and fix the syntax issues as they arrive.

Oh… that’s not what i wanted to hear :confused: So it’s better to switch to HassIO or Hassbian?

This all depends on what you want.

Do you want a simple ‘appliance’ type device that just runs your home assistant stuff? Go with HASSIO

Do you want more control to be able to run other software on the pi, or have access to the underlying OS? Go with hassbian

Well the only thing i need is a device for Home Assistant to run on, but tried HASSIO when it first came out, and had quite a few problems back then. Might have been fixed since then.
Do you know if you can run NodeRed on it now?

Oh that sounds awesome! and nodeRed works just as the one you can install on a normal raspberry pi?

node red is node red no matter where you install it. it is just normal node red.

one thing to note, if you like to access GPIO pins from node red, I don’t know if that works in hassio.

1 Like

Oh okay I see, i think I choose Hassbian tho, just because I like to have the extra options. You have spared me for lots of time searching for a solution, I’m grateful!