Unable to find service notify/pushover

I am having trouble getting pushover notifications set up in 0.80.2, any ideas what I am doing wrong? I am trying to get my plant sensors to notify me when my plants need water, but when it triggers I get this error:

[homeassistant.helpers.script] Script Vanne planter: Running script                                                
[homeassistant.helpers.script] Script Vanne planter: Test condition time: True                                     
[homeassistant.helpers.script] Script Vanne planter: Executing step call service                                   
[homeassistant.core] Unable to find service notify/pushover 

my configuration.yaml has this entry:

notify:
    platform: pushover
    api_key: -
    user_key: -

and automations.yaml has this:

  - alias: 'Vanne planter' 
    initial_state: 'off'
    trigger:
      platform: numeric_state
      entity_id: sensor.plant_1_brightness
      below: 8000
    action:
    - condition: time
      after:  '00:00:00'
      before: '23:59:00' 
    - service: notify.pushover
      data:
        message: "test"
        title: "test"

Home Assistant running in Container Station on a QNAP nas.

Any help would be awesome :slight_smile:

From the component documentation:

  • name ( Optional ): Setting the optional parameter name allows multiple notifiers to be created. The default value is notify . The notifier will bind to the service notify.NOTIFIER_NAME .

Either add name: pushover to the component declaration or change the service call in the automation to notify.notify.

1 Like

Thank you so much, that did the trick! :slight_smile:

I am having a similar problem, and probably you have already explained the solution, but I can’t get this notify set up to run.

  • id: ‘102’
    alias: ‘Fred leaving MDMH’
    hide_entity: true
    trigger:
    platform: zone
    event: leave
    zone: zone.MDMH
    entity_id: device_tracker.iphone
    condition:
    condition: time
    after: ‘11:00:00’
    before: ‘21:30:00’
    action:
    service: notify.pushover_martha
    data:
    message: ‘Fred left Hospital’

with this configuration.yaml file-

notify:

  • platform: pushover
    name: pushover_fred
    api_key: xxxx1
    user_key: xxxx1

  • platform: pushover
    name: pushover_martha
    api_key: xxxx2
    user_key: xxxx2

What am i doing wrong?
Fred:neutral_face: