Unable to get Eufy Light Switch working


I had been struggling to get my Eufy switch thru HA, mainly the integration of the component is not going thru well.
I have the latest version 0.78.3 running and have a fully working Wall switch to my dining table light. This works from the native all on my mobile well.

The error I get during set up is …

2018-09-29 12:31:25 ERROR (MainThread) [homeassistant.setup] Error during setup of component eufy
Traceback (most recent call last):
File “/srv/homeassistant/lib/python3.6/site-packages/homeassistant/setup.py”, line 148, in _async_setup_component
component.setup, hass, processed_config) # type: ignore
File “/usr/lib/python3.6/concurrent/futures/thread.py”, line 56, in run
result = self.fn(*self.args, **self.kwargs)
File “/srv/homeassistant/lib/python3.6/site-packages/homeassistant/components/eufy.py”, line 54, in setup
KeyError: ‘eufy’
2018-09-29 12:31:25 ERROR (MainThread) [homeassistant.setup] Unable to set up dependencies of switch.eufy. Setup failed for dependencies: eufy
2018-09-29 12:31:26 ERROR (MainThread) [homeassistant.setup] Unable to prepare setup for platform switch.eufy: Could not set up all dependencies.

My configuration in switches.yaml is …

Eufy Switches

- platform: eufy

username: xxxxx

password: yyyyy

friendly_name: Dining Light

  • platform: eufy
    - address:
    access_token: zxhydufkekama
    type: T1211
    name: Dining Light

I have tried both the first one [hashed] and then the second one. I did follow exactly as given in the document for setting it up.

Any help will be much appreciated.
Thanks in advance.

I am having the same issue trying to configure a Eufy T1203 Smart Plug, HA 78.3 &79.2. I have tried with the configuration formatted like:-

in configuration.yaml

username: [email protected]
password: !secret

and also


  • address:
    access_token: JZ527J231N8A2Y45
    type: T1203
    name: Smart Plug

but neither configuration shows the device in Home Assistant and I can’t see any errors in the log for Eufy. Did you manage to get this working or does anyone know how to correctly configure the Eufy Smart Plug in HA?


It’s working for me now.
All I had to do was to move the above config details to configuration.yaml from the switches.yaml.