Unable to install all requirements: hass-nabucasa==0.12

After upgrading to 0.93.1 I no longer have the Home Assistant CLoud option in settings in the frontend and I get an error with trying to load the cloud component. In the logs I can see the following:

2019-05-22 12:09:43 ERROR (SyncWorker_8) [homeassistant.util.package] Unable to install package hass-nabucasa==0.12: ERROR: python-jose-cryptodome 1.3.2 has requirement pycryptodome<3.4.0,>=3.3.1, but you’ll have pycryptodome 3.8.1 which is incompatible.
ERROR: homeassistant-cli 0.4.4 has requirement pyyaml>=4.2b1, but you’ll have pyyaml 3.13 which is incompatible.
ERROR: broadlink 0.9 has requirement pycryptodome==3.4.11, but you’ll have pycryptodome 3.8.1 which is incompatible.
ERROR: Could not install packages due to an EnvironmentError: [WinError 5] Access is denied: ‘C:\Users\craig\AppData\Roaming\.homeassistant\deps\Python36\site-packages\Crypto\Cipher\_raw_aes.cp36-win32.pyd’ Check the permissions.
2019-05-22 12:09:43 ERROR (MainThread) [homeassistant.requirements] Not initialzing cloud because could not install requirement hass-nabucasa==0.12

The error in the frontend shows an erorr of:

Unable to install all requirements: hass-nabucasa==0.12

This happens even though it is v0.12 of hass-nabucasa that is installed when I run show version hass-nabucasa.

So it seems like hass-nabucasa can’t installed because it depends on warrant which depends on python-jose-cryptodome which depends on pycryptodome. It seems that when it tries to install it will install pycryptodome 3.8.1 but python-jose-cryptodome 1.3.2 requires v3.3.1 - 3.4.0.

Does anyone have any ideas? No idea why I seem to be the only person effected by this! I regularly upgrade without issues. I’m running on Windows.


Running software designed for a Unix-like environment on Windows is asking for issues. Deploying a Linux VM in VirtualBox would be a better option.
Have you tried using pip to downgrade pycryptodome ?
Something like pip install pycryptodome==3.4.0 ?

I totally agree. When I originally setup HA it was only for one garage door opener. Since then it has spiralled and plan to move over to hass.io on a Pi or something in the future but am stuck for now.

I just tried installing pycryptodome==3.3.1 but I still get the same error. I know it isn’t ideal in Windows but it seems like there is some version mismatch to be causing this. Seems like I am in a catch-22 :frowning:

You could install VirtualBox & install a Debian VM with bridged NIC, so it gets an ip address on your network.
Then migrate your config over to the VM.