Unable to install any addons in Hassio - help!

I’m fairly new to HA and Hassio but I’ve been playing around with Domoticz and OpenHab for a while.

I had a fully working install of Hassio which was able to install addons as expected but I ran into a few issues and decided to reinstall. I installed the same image on the same hardware, running 0.94.4 HassOS 2.12 on an RPi 3.

The error in the log is the same regardless of which addon I try to install.

19-06-25 04:59:26 INFO (SyncWorker_17) [hassio.docker.interface] Pull image homeassistant/armv7-addon-configurator tag 3.4.
19-06-25 04:59:41 ERROR (SyncWorker_17) [hassio.docker.interface] Can’t install homeassistant/armv7-addon-configurator:3.4 -> 500 Server Error: Internal Server Error (“Get https://registry-1.docker.io/v2/: net/http: request canceled while waiting for connection (Client.Timeout exceeded while awaiting headers)”).

I don’t think I did anything differently the second time I installed it, but something’s clearly not happy!

I would not go that route… Try Hassio on RPI 3. You will find that with Hassio you can leverage the native container support to your advantage. Its the better way to approach Home Assistant, for sure.

Does your instance have correclty configured network settings?
Try setting them manually with a usb stick ( see the link above)

So I am using the Hass.io RPI image on my PI and i have a DHCP reservation set on my on my router. This is for my test box which used to be my prod. I have since mover to a debian VM w/ docker CE and Hass.io using the Scripts that Frenck has on his Github site.

Sorry, I might have given the wrong impression - I’m using Hassio

1 Like

I am having the same problem with a fresh install of hassio on an RPi4. Did you ever figure out a fix>