Unable to install Apple TV integration but shows successful installed?


I’m unable to add the Apple TV integration to my Home Assistant setup. What are the steps I took;

  1. Search for the Apple TV integration
  2. Fill in the name of the Apple TV but also tried with the IP
  3. It detects the Apple TV and recognized it’s a model 4
  4. Entered all the Airplay codes
  5. Get the confirmation the integration is installed
    BUT… it’s nowhere to be found, there are also no entities.

What have I tried.
Updated to the latest release of HA OS/Core etc.
Changed the Airplay settings on my Apple TV from everyone on the same network to everyone
Static IP Apple TV
Apple TV and HA are both wired to my network, same vlan and on the same switch
And of course the easy steps of turning off and on the Apple TV and HA

Hope someone can help me with this, almost a week of struggling but no positive result.

Thank you in advance!!


Have you ever ignored the Apple TV integration before?

1 Like

Thank you!! That was it, I indeed ignored it when I started with Home Assistant.

But I think it’s kinda strange that when you manually add the integration it doesn’t stop ignoring.

It may seem that way but it isn’t. When you add a second time you aren’t adding the integration again you are adding another device to integration that was already ignored. So if you have 5 more Apple TV’s you’ll add them the same way and they all show up under the Apple integration with 5 devices, not 5 Apple integrations.

@gieljnssns That was a good catch, I’m not sure I would have thought about that until some back and forth with questions!

I had the same problem last week…