Unable to install on new RPI3


#1

Hey all! I’ve been running into issues while trying a new install of Home Assistant on a brand new Raspberry Pi 3 B+ despite following the instructions to a ‘t’.

I’ve tried flashing both 32 and 64 bit images onto my SD card and put the following configuration into ‘/CONFIG/network/my-network’:

[connection]
id=hassos-network
uuid=55c4c42b-0f73-4783-84a1-c8e8395f5aeb
type=802-11-wireless

[802-11-wireless]
mode=infrastructure
ssid=

Uncomment below if your SSID is not broadcasted

#hidden=true

[802-11-wireless-security]
auth-alg=open
key-mgmt=wpa-psk
psk=

[ipv4]
method=auto

[ipv6]
addr-gen-mode=stable-privacy
method=auto

I plugged a monitor in during the boot process and noticed the issue occurs right after the IP is assigned (using an ethernet connection). I keep getting ‘Failed to receive’ errors while the host tries to fetch the image file over the network.

I’ve tried modifying the network config to a basic ethernet configuration and removing the USB stick altogether. Any thoughts on what might be going wrong?


#2

I am using the same. Raspberry Pi 3 B+. The first image i tried was the 32 Bit flavor (hassios_rpi3_32_1.13.img.gz). I also hooked up a monitor via HDMI, ethernet cable, keyboard, mouse, and “CONFIG” usb stick. I monitored the boot routine on the monitor and noticed that the boot sequence delivered an “ethernet not found:” error.

I then tried booting without the config stick, but with ethernet cable installed and it still returned “Ethernet not found”

I then Reimaged my SD card with 64 bit flavor (hassios_rpi3_64_1.13.img.gz)., and that worked.

Why would one flavor work and not the other? is there something in the 32 bit image that disables the networking?