Unable to link Home assistant with Google Home

Hello there,

I know what you must be thinking, again a question on this topic?
Yes, I am thinking the same, but it seems that after reading a lot of topics on this forum and the rest of the world wide web, I cannot seem to find a solution for this problem.

The problem is a known problem, when I try to add home assistant on the google home app, I get the login screen, but after logging in, it just goes back to the list of integrations on google home without adding my test app.

This is the setup i use:

  • Home Assistant 0.102.3 on a RaspberryPi 4 using Docker

  • Traefik on Docker using SSL and DNS thru cloudflare. With my own domainname

  • Secure SSL connection goes fine to my HASS website

  • I use a Huawai Mate 10 Pro phone with Google Home installed

  • The following is in my configuration files


  project_id: !secret google_assist_project
  api_key: !secret google_assist_api
    - light


google_assist_project: xxxx-000000
google_assist_api: xxxXXxXXxxxxxxXXxXxXx

(Above are ofcourse not my real project id and api key)

What I already tried myself:

  • Did the whole setup about 8 different times (deleting old project and api, making a new one, changing keys and project id in configuration, restarting hass etc. etc.) (Using the official site instruction, and numerous other instructions found on the internet)
  • Cleared history and cache on my phone a couple of times
  • Deleted google home app, and tried again

But the problem still remains, when I try to link my test app to google home, i get to the hass login screen, but after logging in, it just goes back to the devices list and doesnt add my test app.
Next to this, the google resync service in home assistant is giving a 404 not found error, but I heard thats because you need to link your app in google home first?

I desperatly hope someone can help me with this problem, after searching and trying different things, I cannot find the solution.

I have the same problem like you ! Tried to recreate new action, expose just one type of entities but it didn’t work for me. No error but after linking/login, nothing happening in google home…

I fixed it by reinstalling everything, and instead of homeassistant on docker, i know have hassio with hassos… I think it was a problem with the ssl configuration, traefik and such, its always hard to wrap my head around something i am not very known with

Thank you for your response. I not really like this answer lol but I think I will do like you because I have no idea what is the problem… I have activate debug trace for google_assistant but nothing in the log file …

What is your setup you are running?
And if you are using ssl, can you connect your your home assistant server thru the https url?

Thank you so much ! I just realise that my SSL certificate expired on 20th december… I think this is the problem. I will to change it tonight.