Unable to load the panel source: /api/hassio/app/entrypoint.js

same issue on fresh install. Am I doing something wrong?

entering supervisor tab

I guess it only worked immediatelly after installation, but not sure…

Arghhhh - same issue for me

Any work arounds to fix?

1 Like

Same error here. Reinstalled several times, it’s okay for the evening, then next morning the same error Unable to load the panel source: /api/hassio/app/entrypoint.js. pops up. Extremely annoying.

I have the same issue, even after a reinstall. HASS.io on Docker.

Running Hassio in docker on Proxmox 5.4-13 and this is happening to me, 24 hours after a fresh install, even though it wasn’t happening at first.

Mine was within 48hrs. I am there with you. Guessing something is updating and going haywire.

I had the same from overnight - can’t get into Configurator and not a lot has loaded.
Reboot didn’t work.
Remove power cable from RPI for 20 minutes didn’t work.
I have worked around this, hoping its more than a temp fix though, by SSHing into the RPI on port 22222 and doing a restore from last backup:

ha snapshot -----> make a note of the slug id - restore point
ha snapshot restore "2997e2ca"

Seems to have worked so far however root cause probably still remains

Had it as well a few releases ago. Reinstalled a few times, but didn’t succeed in getting rid of the issue. At some point I tried removing some integrations, and at some point the issue was gone. I believe that the MariaDB was the one causing the issue for me, but I’m totally not sure of this… Maybe it helps someone, maybe not…

Problem solved (with a rpi)
I did pull the power off the rpi, with no normal shutdown. (so just a ordinary powerbreak :wink:
After reboot HassIO did fixed himself and the error /entrypoint.js is gone.
It worked in my case and i have read in a post on the github of hassio
Good luck!


So, I tried this, no success by at least turning it off. It was an independent docker image, in my install.

So, found a thread on github, that leans towards this issue being caused by other docker apps, specifically eyeing Watchtower. Seeing as I am moving more into HASS.io, vs individual docker apps deployed outside of the supervisor, I felt this wasn’t a big issue and removed watchtower. If/when I re-find the suggestion, Ill link it to this post. Ill truly feel this fixed the issue, if it holds for a few days.

If I recall correctly, I really removed the MariaDB addon completely so the docker image was gone as well.

Removed Watchtower, restarted Hassio, no go.

I disabled (not removed) Watchtower. It seems to have fixed the problem - for now

I had this same error appear this morning. Im running hassio through Window Hyper V.
I tried several things, but shutting the virtual machine down and restarting seems to have done the trick, so a simple power off and on again may fix this (a restart through homeassistant didn’t work for me)

Same issue here. Will try powerdown, restart from HA doesn’t work.

Same here, on the latest 107 on rpi3. I can see my sensors and use some switches but performance is VERY poor and the developer tools do not work either. SMB access is also not possible.
I tried rebooting, but now the connection times out before the UI is visible.

Had the same issue. My install method is Ubuntu with HA loaded onto this. It is a case of updated the Ubuntu OS. I ran through the following commands, rebooted and it works

Also having this issue, appeared overnight on my Docker installed Hass.IO on Ubuntu.

Hassio on rpi4 did this as well. ssh in (via a terminal, not web interface as that did not work) and rebooted. it came up fine. looks like the supervisor got a few updates yesterday…