Unable to load the panel source: /api/hassio/app/entrypoint.js

Getting the error Unable to load the panel source: /api/hassio/app/entrypoint.js when attempting to open Configurator, Hass.io, and Node-Red pages (appears to be any page managed by Ingress). I’m on Hassio on a RPi. Home Assistant v0.95.4. Any ideas how to fix this?

Background: We had a power outage the other night. When the power came back on, I had to ssh into the rpi and manually start hassio homeassistant start. It came up fine, and Hass.io and Node Red worked fine. A few hours after that, Hass.io and Node Red and Configurator stopped working (can’t open them, my Node Red flows aren’t functioning) and I am unable to access their pages.

Troubleshooting steps:
I’ve restarted Home Assistant hassio homeassistant restart. No joy.
I’ve rebooted the RPi. No joy.
The HA log gives a similar error message: Client error on api app/entrypoint.js request Cannot connect to host 172.30.32.2:80 ssl:None [Connection refused].

The 172.30.32.2 IP is not on my network, but research leads me to believe its an internal IP address used by the Hassio docker system.

I’ve found a few similar threads on this forum and the reddit forum, but nothing conclusive. I’d like to avoid re-imaging my SD card if at all possible.

Edit: After the power outage I’m seeing many more warnings and errors that my thermostat and darksky and presence sensors are taking longer than 10 seconds to update (update of [SensorName] is taking over 10 seconds). Don’t know if this is related or not.

SOLVED: For posterity: I hard unplugged the rpi from the wall. Waited a minute, plugged it back in. SSH’d in, started home assistant, and it all came up just fine. I’m working again, but I’m very very concerned. Don’t like having to hard reboot to solve a problem. I’m guessing that the power outage scrambled my containers somehow, and by hard rebooting I reset them to a good configuration. Not sure why restarting HASSIO and restarting the RPI didn’t do that, but…

2nd EDIT: A few weeks later my SD card completely died and I had to buy a new one and start from scratch. I believe the above issue was a symptom of my card failing. If you’re getting this as well and your configuration looks good, you may want to take some precautionary steps for an SD card about to die (backing up, get another SD card ready).

5 Likes

I’ve just encountered the same issue, no power outage that I am aware off but got the same error you did when loading the same screens.

I’ve powerred off the RPI for 5 minutes and then turned it back on and now I can’t connect to it at all, even connecting via ssh refuses to connect.

I didn’t back up hassio before powering off as I thought the error may be backed up, now I wish I had as I can imagine I may have to start from scratch again

1 Like

Check here, looks like the issue has been ID’d. If you have a way to modify your secrets.yaml via access to your host, you should be able to fix it.

https://github.com/home-assistant/hassio/issues/1292#issuecomment-531550991

Same on 0.97.2. But without any power outtake or anything. System was just running and running

1 Like

I reinstalled yesterday my hass.io system completly new (other reasons), migrated my config the the new system and also got the error. I also have the latest version installed. I did not see any new version or fixes on github. Is there maybe an other solution for that problem?

I reflashed my pi yesterday and think I have everything set up again now, not getting the errors any more.

1 Like

Just go to user menu on the left and be sure advanced mode is on. This was the solution for me after a fresh install of the Hass.io package on synology DSM.

1 Like

Hello, this error occurs when installed with the hasssio package on synology.

Current issues

The installation process does not play nice with the Synology Firewall (or Adguard/PiHole) and could show errors like this below. Make sure to disable the Firewall before starting the installation (thanks @ohminy for pointing this out).
Copy to clipboard
[hassio.utils.dt] Can’t fetch freegeoip data: Cannot connect to host http://ip-api.com/ ssl:None [Try again]
[hassio.updater] Can’t fetch versions from https://version.home-assistant.io/stable.json: Cannot connect to host version.home-assistant

Sometimes there are communication issues between Home Assistant and hass.io 16, with this error message : Unable to load the panel source: /api/hassio/app/entrypoint.js. Restarting the package seems to fix this or follow the fix below.
Fix: (I don’t think it is possible to make this automatic atm)
Stop the package (from Package Center).
Go to the Docker package page and find the hassio_supervisor Container (under the Container tab).
Stop the hassio_supervisor (if it still is running), right click and choose Action -> Clear.
Make sure that the homeassistant container is stopped.
Start the Hass.io 50 package from Package Center.
Wait a minute and make sure that the homeassistant container is started (in the Docker package) or start it manually.

source: Hass.io on Synology DSM (native package)

1 Like

Did you manage to get it to work?

Where do you find that panel? Could you share a screen shot?

image

1 Like

I just did update to 206 and have the same issue. I have hassio installed on docker.

Give it a few minutes, that’s because it can’t load the supervisor page that’s been updated. It should come back up

Same issue here after update to 106.5.
hassio installed on docker + nodered + hacs

“on docker” :roll_eyes:

You didn’t choose to install on docker or not. You chose a different Operating System.

Those running on generic linux installs (not “on docker” installs) need to run through the install steps again.
https://github.com/home-assistant/supervisor/issues/1556#issuecomment-594079796

2 Likes

Just encountered this issue, installed 106.5 a few days ago and it was fine till tonight…

Running hassio, how can I fix it?

Same here… installed 106.5 a few days ago and yesterday the supervisor panel is not working.

Also running on hassio

1 Like

Had similar issues, fixed with steps posted on: https://github.com/home-assistant/supervisor/issues/1556

sudo -i docker pull homeassistant/amd64-hassio-supervisor:latest
sudo docker tag homeassistant/amd64-hassio-supervisor:latest homeassistant/amd64-hassio-supervisor:latest
1 Like

Those of us on Hassio can’t run sudo commands.
-bash: sudo: command not found

What now for us poor bastards on docker?

Can’t load supervisor, esphome, configurator…

I believe this is the related error:

2020-03-10 09:42:38 ERROR (MainThread) [homeassistant.components.hassio.handler] Client error on /homeassistant/info request Cannot connect to host 172.30.32.2:80 ssl:None [Connect call failed ('172.30.32.2', 80)]
2020-03-10 09:42:38 WARNING (MainThread) [homeassistant.components.hassio] Can't read last version: 

Edit:
Just chatted with cogneato on discord and solved the problem
Run ha su repair through ssh.
First time it didn’t run, power cycled the Pi and ran it again and now it’s repaired and working.
Thanks @cogneato!

2 Likes

Hey! Same error for me , not using docker.

I received the error message:
Post http://supervisor/supervisor/repair: dial tcp 172.30.32.2:80: connect: no r oute to host

When trying to do the command above through SSH

Edit: Just rebooted the PI and now I cant even SSH. Says connection refused.