Unable to load the panel source: /api/hassio/app/entrypoint.js

I just experienced this fault. It started yesterday as we where going to bed, had done nothing to my system at that time so completely out of the blue.
This morning I started to search around for a fix.

My system:
Rp 3b
SD Card
HA 107.7 (had not updated at that time)
HACS installed

Since I couldn’t get in to the supervisor I was unable to reboot the system. I have SSH add-on (Terminal & SSH) installed, but the somehow the configuration of the port was set to “null”. So I could not get into the system to reboot. The only thing left was to pull the plug :pleading_face:
I was lucky and the system booted up fine.

As soon as the system was up I made a new full snapshot.
Then I looked into the ssh problem and found the issue with the port, I changed that to 22 and made sure ssh worked by using the terminal.

Then I updated the system completely to the latest HA and operating system.
So far the system is working fine, I only had one invalid config. That was an add-on from the HACS, spotcast. This add-on had recently stopped working because of Spotify changing some things. I don’t think that caused this fault on my system.

If my SSH would have been working I would have tried this before doing a hard reboot.

This really made me question having my system on an SD card for sure, I have had this install since late last year with no issues and a great setup I rely on. If I have the same fault again I will report back.

I had same issue this morning and fixed it. I’m running Home Assistant version 0.108.9 and Supervisor version: 220 on OMV Docker. From Portainer I restarted Supervisor and everything seems working now.

This issue appeared for me last night out of nowhere. No changes had been made prior. Could not access Supervisor, Configurator, Terminal. Restarted HA, and didn’t help, made matters worse as SSH no longer worked.

Phew! Power-cycled RasPi, and back to normal (for now).
On supervisor 202 220, HA 108.6.

I ran ha core rebuild on CLI and after it rebooted everything is working.


happened twice yesterday, on NUC and RPI and happened today upgrading to version 0.109.3 in my RPI.
REALLY annoying!
I can’t access the panel and have invalid access token log about every addon and supervisor panel.
I’m rebooting to see if can fix by itself, but this issue should be addressed, 220 version, with HA 0.109.X, is really a mess.
edit: ok reboot fixed nothing, still have tons of error log:

20-05-03 10:18:32 ERROR (MainThread) [supervisor.api.security] Invalid token for access /app/entrypoint.js,
20-05-03 10:18:55 ERROR (MainThread) [supervisor.api.security] Invalid token for access /addons/core_mariadb/info,
20-05-03 10:18:55 ERROR (MainThread) [supervisor.api.security] Invalid token for access /addons/a0d7b954_nodered/info,
20-05-03 10:18:55 ERROR (MainThread) [supervisor.api.security] Invalid token for access /addons/a0d7b954_nginxproxymanager/info,
20-05-03 10:18:55 ERROR (MainThread) [supervisor.api.security] Invalid token for access /addons/a0d7b954_pi-hole/info

I fixed this time doing ha core rebuild in hassio_cli.
Have to check if this will mess up again at every upgrade or not.

1 Like

The additional issue for me running Home Assistant (not Core) is the SSH & Web terminal Add-on failed to start so it was impossible for me to access the HA CLI. The only thing I could do was power-cycle.

Now, lesson learned here is that when this error first occurred, the SSH addon was still working, but I did an HA restart as a normal first resort but this prevented SSH from restarting.

What I really need for insurance is an SSH daemon that runs independently and not dependent upon the Addons not starting due to other HA issues. So I would have to abandon Home Assistant and go the Core route to achieve that?

i don’t know about that addon but i have ssh running as OS service, and so i do for portainer: i have both addon and “native” version installed: if something get screwed HA side, like happened, i’m still be able to access services and do things…if everything goes well i access it from HA, just more easily.
hassio_supervisor is like an orchestrator for all addons, if it get screwed, it could block everything, and some addons doesn’t start by just starting from docker, this is a BIG issue.

Thanks for the advice, but again, I’m not running Core, so I’m not sure what options I have for installing SSH as a dedicated service on HassOS.

Thanx! I had 219 installed and running and all of a sudden it stopped working. Followed your steps and everything works again, installing 220.


I am totally new to this. I have spent 4 hours on it now. I installed duckdns, updated the config file > right click > restart hass. Now i have this error. I have re-flased it once already… what should i do?

I have installed HA from scratch 4 times now. I have also bought a new micro SD card.
I bought my RSP4 yesterday. This really sucks. No one knows what’s wrong. It feels like wasted money…

When I restart Hass, doesn’t matter if i install an addon, then it will crash.

@Johnyyy was setting up duckdns with ssl and then restarting HA, and then not using https:// to access the new configuration. It was never crashing. It was doing exactly what was expected.

@GaryOkie When you restart HA you are only restarting HA. No other add-ons are restarted along with it. So the SSH add-on is already independent. All add-ons are separate containers.

1 Like

Thanks @cogneato for the explanation of how the independent SSH docker should work. I can only say that in this particular instance when encountering this entrypoint error that the SSH daemon was definitely not responding after a restart. I agree that it doesn’t make sense why this could have happened.

This situation is so rare that I’m not going to worry about it and look for an additional backup SSH capability. I already have a remotely accessible power switch for the router and HA server, so if things go south when away, I can attempt a hard restart recovery that way.

I have the same problem on Supervisor page. Resource http://local_ip:8123/api/hassio/app/entrypoint.js returns 502 error. I can’t access the Supervisor page. Version 0.109.2.


Client error on api app/entrypoint.js request Cannot connect to host ssl:None [Connect call failed (‘’, 80)]

Due to this problem I can’t even restart the homeassistant using web interface:

Client error on /homeassistant/restart request Cannot connect to host ssl:None [Connect call failed (‘’, 80)]

Same here as of this morning - presume there was a supervisor update overnight that’s b0rked??

1 Like

my error was that i installed duckdns. i had to use the new adress.,

HA 0.108.9 running on Hassos Rpi 3b+:

Same issue here, nothing updated by myself so that’s confirm a supervisor update overnight that’s b0rked.

And here also


Cannot load Supervisor

Home Assistant 0.109.5

Shall I wait for a fix?

Mine randomly started working again a couple of hours later. I have no idea what caused it but I didn’t do anything to fix it, it just came back by magic.

(although yes, the supervisor did update overnight so I guess, however tenuous the link, that was the ‘cause’)

There is an open issue for that? Just to know that someone is working on…

1 Like