Unable to log into new companion apps with error [aiohttp.server] Error handling request

Hi there.
Today, my existing companion apps are working and I can log in to HA from any browsers.
However, if I try to connect on a new companion app (iOS or Android), or even just logout to an existing one and try to log back in, I’ve got the following error after the connection page (so the app can connect correctly to my instance as I see the login page)

On the server logs, I’ve only got this without any details : ERROR (MainThread) [aiohttp.server] Error handling request

I’ve tested with different situations with always the same result :

  1. HAOS on a Pi5, NGINX Home Assistant SSL proxy and Let’s encrypt, and clouflare proxied DNS entry
  2. Docker container, Traefik proxy and Let’s encrypt certificate, and DNS with direct IP

Same issue on both case, and same issue on Android and iOS companion, and no issues on any web browser.

Connecting to the remote DNS address or to the local IP (when on my local network) gives the exact same error.


so you can login to the app then get an error? what error do you see in the companion app logs?

Sorry @dshokouhi didn’t see you answer. I managed to solve the issue… by disabling Nabu Casa