Unable to logon to Home Assistant mobile app

I got myself a new Chinese tablet to be used with a wall mount. I installed Hasskit but it would not let me connect to Home Assistant. So I tried something simpler. The Home Assistant App. I got the same error there, so it’s not related to Hasskit.

This happens: I start the Home Assistant App. It asks me for the HA web adres. I enter the correct information and press OK. The “logon” screen appears but without an option to enter username and password.

When I press OK, it gives an error.

This is my setup: Home Assistant 0.105.2 on Docker on Synology, HA Cloud (trial) activated, Remote UI on, Google Assistant on.

I already tried some things.

Changed the BASE_URL in my configuration.yaml from http://www..net to the nebucasa address, and also to my local IP-adress. No change.

Logging in on the tablet from Chrome. No problem.

Installing Ariela and configuring (entered username and password in Ariela, not through web logon). No problem.

In the configuration.yaml I put entries for trusted_networks and trusted_users. Works fine on my Phone and other (Samsung) tablet, but not on the Chinese tablet. It gives the option to switch from Local logon to Trusted Network logon, but both don’t work. After that I removed the entries again.

I checked the Chinese tablet. It is sold as Android 9.0, but when I click the Android version under “About my phone”, it comes up with a nice Nougat logo. So I assume it’s Android 7.0.

Does this device have google play services? Judging by the screenshot it seems the webview did not load the page properly.

Yes, it has Google Play Services. Regarding your remark about webview I did some more research. I could install Android System Webview eventhough there was already a Webview component present. Still I get the same error from my HA website.

In Developer Options there is an option called “WebView implementation”. It gave (and gives) just one option: “Android WebView”.

I installed WebView Test, by SNC Soft and loaded up the my Home Assistant webpage. The first error I got was:
[ERROR] "Uncaught (in promise) TypeError: Object.entries is not a function", source:// (line 2)

Any idea what to check next?

if you were able to install android system webview, then try the rest of these steps: Custom ROMs and WebView issues

You will need to be rooted for this.

Thanks for the tip. I tried rooting my tablet and even resorted to those one-click rooters (Kingroot and such). I keep on bumping into issues, and the last one is that I’m missing a ‘pwn’ file in MTK Droid Tools… Unfortunately no luck in rooting so far.
I will keep trying and looking into that WebView problem some more. I think maybe its possible to uninstall the default WebView from the tablet using adb.