Unable to read file inside config folder (homeassistant supervised installed in DSM7)

Hello everyone, I have some issues about HA not able to read files under /config folder when I check the configuration.

The error is:

Error loading /config/configuration.yaml: in "/config/configuration.yaml", line 20, column 20: Unable to read file /config/SERVICE_ACCOUNT.JSON..

But I am positive the service_account.json is inside the /config folder

I’ve tried

chmod 644 /homeassistant/config/SERVICE_ACCOUNT.JSON

using SSH to my DSM 7 but it return

chmod: cannot access '/homeassistant/config/SERVICE_ACCOUNT.JSON': No such file or directory

So I tried

find / -name "SERVICE_ACCOUNT.JSON" 2>/dev/null

And it return

/volume2/docker/homeassistant/config/SERVICE_ACCOUNT.JSON

So I have no idea what’s going on.
Could it be a permission issue? or is the path not correct?

Some info:
Homeassistant is installed inside docker, and the docker folder inside my DSM 7 in volume 2 ( not the default volume, I changed it the volume 2, since my volume 1 is HDD and volume 2 is SSD.)

Any help is appreciated :grinning: