Unable to remove Synology Integration

After installing a new SSL cert on my two Synology DSMs, the integration stopped working. I was going to remove and re-add the integration, but I am not seeing the typical three vertical dots for the integration control. All other integrations are working fine. I have tried restarting the core with no luck. The following log entries are found:

2021-05-20 18:19:49 WARNING (MainThread) [homeassistant.components.synology_dsm] Connection error during update, fallback by reloading the entry
2021-05-20 18:20:38 WARNING (MainThread) [homeassistant.bootstrap] Waiting on integrations to complete setup: synology_dsm
2021-05-20 18:21:38 WARNING (MainThread) [homeassistant.bootstrap] Waiting on integrations to complete setup: synology_dsm
2021-05-20 18:22:38 WARNING (MainThread) [homeassistant.bootstrap] Waiting on integrations to complete setup: synology_dsm
2021-05-20 18:23:38 WARNING (MainThread) [homeassistant.bootstrap] Waiting on integrations to complete setup: synology_dsm
2021-05-20 18:24:06 WARNING (MainThread) [homeassistant.bootstrap] Setup timed out for stage 2 - moving forward
2021-05-20 18:29:06 WARNING (MainThread) [homeassistant.bootstrap] Setup timed out for bootstrap - moving forward


Since I could only imbed one image as a new user, here is the second image:


Also, I noticed if you try and add another instance, the default is “Uses an SSL certificate”. So, I assume that it is not happy that the cert has changed. Again, this would be solved if I could delete the old integration and re-add it. Otherwise, I need to find out another way to either clear the cert or the integration.

This is really strange - if there are no dots on main screen, when you select specific device, it should be seen.
In terms of certificate, changing one shouldn’t make that big of a difference. Problem here could be if you were using self signed certificated for IP address and alter changed this to public domain certificate (for ex. duckdns domain). As it doesn’t match the IP address.
One other thing that I’m 99% sure isn’t the issue, but if you can check/verify, you can eliminate that - did you maybe have Synolgoy setup in configuration.yaml file? Before it was transferred to UI integration?

Thanks for the reply. I can confirm that there was no entry in the configuration.yaml for either Synology. Yes, the previous self-signed cert would have been for the IP address. The cert is based on an fqdn.

Ok… Dumb question, but do you have NAT loopback/NAT hairpin setup?
So that HA can resolve FQDN to interla IP address, and not external?

Not sure I follow the reference completely. HA points to my internal DNS. The FQDN for the synology resolves internally.

Got around the issue by re-generating an IP-based self-signed cert for each NAS. For whatever reason, this made the integration available again. I deleted the integration for each, changed back over the the FQDN cert and re-added the integration. Working now with the FQDN based certs.

No further action needed. Thanks.

Same problem here, but not enough knowledge to copy your solution :frowning: Where did you create the cert’s I assume it’s on the NAS, but I am not sure.

Try: Control Panel - Security - Certificate

Still unsolved…probably because my ip-range changed after a new modem/router