Unable to remove unknown listener <function async_track_point_in_utc_time.<locals>.point_in_time_listener at 0x7f457a9ad3b0>

Does anyone know what this error message stands for (HA 0.105.1)?

Protokolldetails ( WARNING )

Thu Feb 06 2020 15:02:06 GMT+0100 (CET)

Unable to remove unknown listener <function async_track_point_in_utc_time..point_in_time_listener at 0x7f457a9ad3b0>

1 Like

I have the same error since 105.1 no idea it’s coming from. I think from an automation but have no clue. Maybe someone else?

1 Like

i have also started getting this since .105, i would love some help finding it. I did some searching and there were some mentions of it when using delay in automations. so i tried changing format from

delay: 00:00:30

to

delay:
  seconds: 30

these changes did not seem to help, i also restarted homeassistant a few times without help.

looking though the breaking changes again and my history of some sensors I am wondering if the statistics sensor could be to blame, I am going to do some testing but was wondering if any of you experiencing this issue use statistics sensor for anything.

Indeed I use many statistical sensors also.

As a test i have removed " max_age: " from my statistics sensors and so far its been 3 hours with no warnings, still to early to tell but I will update here when more time has passed. Are you also using " max_age: " in your statistics sensor setup?

1 Like

Yes I also use max_age in all my statistical sensors.

I just did a quick test, and it appears that this may be a combination of 2 things: Having a time_date sensor and having a statistics sensor with max_age set.
I can see that this error message appears while the statistics sensor is updating, right after removing its own listener successfully. When I remove the time_date sensor, the error message does not appear anymore when the statistics sensor updates.

I can look into this further later today.

I am not using a time_date sensor in my config, however after removing max_age: from my config i haven’t had any errors for eight hours now. So for me at least this is my issue, I guess i will need to rework my automatons accordingly.

OK, maybe the time_date was a red herring. I just saw that the async_track_point_in_utc_time I introduced to the statistics sensor also has an embedded callback called point_in_time_listener.

1 Like

I think this is a bug… not sure if it was already reported.
I do understand that because of the state ‘unknown’ any possible automation would need to be adapted to consider that possible state but this Warning in my case is not showing because of an automation… if you simple have a statistical sensor with max_age just for information only… then the warning is shown anyway.

ok… issue confirmed.


Issue was opened by the same person that did the change :slight_smile:

3 Likes

Well, let’s presume I’m innocent until proven guilty. :wink:

3 Likes

Well… I call that efficiency. Wish that everyone I work with would do the same :slight_smile:

2 Likes

I see that the issue was closed but don’t know how to find what release the fix is in.
I’m running 105.3 and still experiencing it,

The fix has not yet been released.

2 Likes

I’m on 0.105.5 and am still seeing these warnings.

1 Like

Late to the party, I updated HA to 0.105.5 yesterday evening and woke up to a bunch of these warnings as well. Also have these max_age and stats sensor configs.
Let’s see if things can get fixed in 0.106 :wink:

This is strange. As far as I know, I don’t have a statistics sensor configured anywhere, unless it’s getting it from Node-Red, or a weather sensor, I don’t have any statistics sensors configured in my configuration.yaml.

This issue is not limited to the statistics sensor alone, but rather to integrations that track a point in time. It’s just that the statistics sensor appears to be particularly prone to this issue in a busy system with many updates in a short amount of time.

1 Like