Unable to restart, because core cannot be stopped

Possibly the wrong place for this but I think my issue falls between categories, every time I try to restart HA (whether by update or by manually restarting it) it crashes. A bit of investigating into logs seems like HA can’t be stopped for some reason. The last message “cannot remove - tried to kill container, but did not receive an exit event”. Nothing happens after this point. Trying to restart HA core doesn’t work (start: it’s already running, stop: can’t stop it). The only way I get it back is by rebooting the host. Any ideas on what might be causing this?

Post the log if what you are seeing

I’m finding it difficult to do this, because my installation is active right now and the log doesn’t go back that far that I can see. The errors I have found (and detailed above) were in the host log visible live as the shutdown was occurring and I don’t know how to find them while the host is running to get a copy.

There is nothing prior to “cannot remove - tried to kill container, but did not receive an exit event” other than previous attempts to kill the container unsuccessfully, that would indicate anything that I can see, which is why i asked “Any ideas on what might be causing this?”

Maybe if there’s something specific I can look for next time this happens it would be helpful.

This is docker? How are you stopping or upgrading.

docker stop <container id>


docker kill <container id>

I’m running on a rpi4 with home assistant OS, using the upgrade button in the UI. When it sat there for hours doing nothing I logged in via SSH to see what was going on and found in the host log that it was unable to kill the container.