Home Assistant Community

Unable to restart Homeassistant, Error executing service <ServiceCall homeassistant.restart

#21

Same problem here, same error in log. If I keep hitting restart, after a few errors it picks up and restarts. But it takes a very long time before I can call the UI again.

Also get this in the log after restart:
2018-12-23 15:03:28 WARNING (Recorder) [homeassistant.components.recorder] Ended unfinished session (id=4 from 2018-12-22 17:30:55.496863)
Don’t know if it’s related.

#22

Logged an issue in git.

#23

Just an FYI. I ended up clearing my db file (it was over 1gb in size), and now my restart button works.

#24

THat’s not really a fix. Why was the bug closed?

#25

I believe I’m seeing the same thing in my HA in Docker on Synology. I basically have to start/stop the container for reboots. My db is in MySQL, so I don’t think the db size is my issue.

#26

I started seeing this on .80 and am still seeing it on .84.

Does anyone know if this is going to be fixed or if it’s even acknowledged as an issue?

#27

I am running into the same problems, any solution?

#28

I finally ended up deleting my database to solve this as has been suggested, but it seems like a crappy non-solution.

I was never able to find anywhere it has been acknowledged. My recollection is that somewhere further up this thread someone filed a bug and the bug was closed telling them to delete their DB, which isn’t a fix.

#29

After an update to 88.2 I cant use the HA restart service… anymore

#30

I have also restart problems and unable to create snapshots. my home-assistant_v2.db file size is 1.66GB, any solution?

#31

Based on my experience the issue is that the DB gets too large. This is especially so if you are running HASSIO on a SD card.
your immediate solution is to delete the DB and restart. Long term solution is to keep the DB to a much smaller size. See https://www.home-assistant.io/components/recorder/

I personally run these settings which keep my DB at around 250MB. Although I have since also moved my HASSIO from my Pi3 to an old laptop with SSD.

    #cleanup DB
    recorder:
      purge_keep_days: 5
      purge_interval: 1
      exclude:
        domains:
          - automation
          - weblink
          - updater
          - zwave
        entities:
          - sun.sun # Don't record sun data
          - sensor.last_boot # Comes from 'systemmonitor' sensor platform
          - sensor.date

Hope this helps someone.