Unable to restart Homeassistant, Error executing service <ServiceCall homeassistant.restart


#1

I’m running version 0.80.0 on Raspberry pi 3 with hass.io It appears to be something in my YAML but i cant find what or where. I searched for the supposed variable “result” from the log but cant find that anywhere. Any ideas on where and what to loo for? I do have my config files separated with packages. Could that have something to do with it?

Error executing service <ServiceCall homeassistant.restart (c:6430b6fe9b09437bbfb5cb88f2ef16c1)>
Traceback (most recent call last):
File “/usr/local/lib/python3.6/site-packages/homeassistant/core.py”, line 1177, in _event_to_service_call
await service_handler.func(service_call)
File “/usr/local/lib/python3.6/site-packages/homeassistant/components/hassio/init.py”, line 264, in async_handle_core_service
error = await async_check_config(hass)
File “/usr/local/lib/python3.6/site-packages/homeassistant/components/hassio/init.py”, line 147, in async_check_config
if result[‘result’] == “error”:
UnboundLocalError: local variable ‘result’ referenced before assignment

another error that usually gets logged at the same time.

Error on Hass.io API:

and this one.

Timeout on /homeassistant/check request

I would appreciate any help. Thanks,


#2

I think it’s a bug. I just updated from 0.79.x to 0.80.1 and now suddenly I can’t restart it either. Pressing the Restart button in the UI does nothing, and hassio ha restart from SSH produces

Error decoding json invalid character ':' after top-level value: 403: Forbidden

#3

Now that you say that I also started seeing this after going from 0.79 to 0.80. just upgraded to 0.80.1, same issue.


#4

I don’t think its anything specific to 0.80.1 and restarts as I upgraded a little while ago and I am able to restart fine. Did you click the Check Config button before clicking restart just to make sure everything was valid in your configs?

I’m on HassOS 1.11 Hassio Supervisor 137 and HA 0.80.1

I guess it could be linked to specific components you are running. @rudyberkvens I also have packages in configs so not specifically that either.


#5

Just putting in my 2 cents… Was getting same error as Rogersmj above.

I tried updating to .80 and can’t get it to boot all the way. RPi returns a ping but SSH connections are “refused”. The webpage gives me the HA logo and says “Retry”. Ended up reformatting/installing twice with same result.

Downgrading now by reinstalling .79.3 again. That was working fine.


#6

It’s definitely a bug in 0.80. I didn’t change anything with my config (which validates anyway). The only thing I did was update to 0.80.1 from 0.79.3 and now I can’t restart.

I don’t know what this means, but I see this in the Hass.io system log:

18-10-17 00:01:37 WARNING (MainThread) [hassio.api.security] /homeassistant/restart no role for a0d7b954_ssh
18-10-17 00:01:37 ERROR (MainThread) [hassio.api.security] Invalid token for access /homeassistant/restart

#7

Restart works fine for me on 0.80.1 it must be some aspect of your config / components that’s different.

… auth / security

I did have issues before after an update with writing to the mem card that was failing … that was just unpredictable results, wouldn’t reboot and a new SD card sorted it.


#8

I’ve had enough of 3 days of nonstop hanging, failing, disappearing entities, random error messages, rebooting, reloading, restarting. I have just ssh’ed to [email protected] and executed:

core-ssh:~# hassio homeassistant update --options "version=0.71.0"


#9

I restored to 0.79.3 just now. and after a few hours of getting my config back to where it was things are running great now. Much faster also. I was running between 3-4 load with 0.80 adn 0.80.1 now its down between .5 - 1.5.

Seems that whatever is causing the reboot issue is also causing general slowness.Or maybe the slowness is the cause of the reboot issue (simple timeout) but then what in 0.80 is causing the sowness.

I’m gong to stay here on 0.79.3 for a while. hopefully someone will find the cause. I cant spend time upgrading again and risking the same issue.


#10

On 0.80.2 - I have the same problem


#11

how do we get this to recognized as a bug and be worked on, please?


#12

@mortenlyng I would suggest raising a bug report in the appropriate repos issues here https://github.com/home-assistant
As you feel is a HA thing probably this one https://github.com/home-assistant/home-assistant/issues

After checking the list of existing ones to see if anyone else has reported it of course.


#13

@allan thanks. For some reason, one of my restart attempts picked up. Not sure why.


#14

I experience the exact same issue running 0.81.0. Running on a Raspberry Pi 1 Model B.


#15

Having the exact same issue on 0.80.3 running on a Pi 3B+. HassOS 1.11 / supervisor 138.

Spent the last week disabling and re-enabling pretty much everything to see what was causing restarts to time out / not work. I commenting out lots of things, disabled components, addons, etc… At this point I’m pretty confident its a HassIO bug. Glad to see that I’m not the only one experiencing this.


#16

I registered this issue on Github: https://github.com/home-assistant/hassio/issues/786


#17

Could you guys be using “Alexa as media player” addon?

Last change on my HA was that this addon was spamming me to reauthenticate it with my alexa and asking for captchas, so i disabled it and it seems to be good now.


#18

I just updated to 0.84.5 this moring and now I cant use the HA restart service…

error:

Sat Dec 22 2018 10:21:07 GMT+0800 (Australian Western Standard Time)

Error executing service <ServiceCall homeassistant.restart (c:9a76b208c012438ea9a8cda203fea2e5)>
Traceback (most recent call last):
File “/usr/local/lib/python3.6/site-packages/homeassistant/core.py”, line 1130, in _safe_execute
await self._execute_service(handler, service_call)
File “/usr/local/lib/python3.6/site-packages/homeassistant/core.py”, line 1143, in _execute_service
await handler.func(service_call)
File “/usr/local/lib/python3.6/site-packages/homeassistant/components/hassio/init.py”, line 268, in async_handle_core_service
error = await async_check_config(hass)
File “/usr/local/lib/python3.6/site-packages/homeassistant/components/hassio/init.py”, line 148, in async_check_config
raise HomeAssistantError() from None
homeassistant.exceptions.HomeAssistantError

any ideas??


#19

updated to 0.84.6 and still have the same problem. I can SSH in and restart, but not from the GUI


#20

Same here on v0.84.6