Unable to send notification to android app

I’ve been using signal to get notifications from my Home Assistant server, but since i made my server available from the net for Amazon Echo I am considering to use the companion app for notifications.

However I am not receiving anything on my phone with this simple test:

service: notify.mobile_app_redmi_note_7
  message: Test

Interesting thing is, that I recall that notification were working previously, actually I still see some notifications in my app’s notification history back from january. I also did try the notify.notify service, but with the same results.

What I am doing wrong here?

Im not sure if its mandatory to have a title too

I don’t think title: is mandatory. It works for me without.
Have you checked your logs for any clues?
Is there phone app communicating to HA otherwise?

there is nothing in the logs. the entities from the mobile app are getting updated in home assistant regularly, also the app is working, controlling HA normally, so I assume everything is normal there. Also I did restart my HA instance several times.

I cannot send a message without adding the following data. It also doesn’t work when called from automations, only scripts for some reason. It’s on the “to do” list to find out why but it works for now.

alias: Notify pixel 3
  - service: notify.mobile_app_pixel_3
      message: test message
      title: Camera
        channel: alarm
        ttl: 0
        priority: high
mode: single

i tried a different device, and the messages are received correctly. it seems my phone ignoring them. tried reinstalling the app, but it did not help. and its not about notifications being disabled on the phone…

EDIT: i forgot that the companion app also creates an integration. Removing the integration and erasing the mobile app data helped and notifications now work