Unable to start HAS after upgrade


I upgraded HAS from 0.49 to 0.56 on my ubuntu 16 installation, upgrade went well, but now i cannot start HAS, i get the below

any assistance

would be great


what does your homeassistant.log in the config folder say? filter for any lines that say “ERROR”. Also, when upgrading, even minor revs, always check the breaking changes notes on the release. I’m guessing there’s a component you use that had a breaking change applied to it between 0.49 and 0.56.

nothing of interest in the log, i renamed it to .old and tried starting again, but its not creating a new file?

Im lost

I think i somehow have some odd install

I have a hass.service which throws a 217/user error and i have a has.service which throws a 203/exec error

Sounds like a permissions issue on the user/install. Hopefully someone with more knowledge than me comes along. Unfortunately I don’t have any experience with installing HA as I run a docker container on a NAS.

Make sure there isn’t a breaking change between .49.and current that is causing your issue. Read all the changes for all the in between updates. Lots has changed.

A quicker way to check this is to backup your configuration.yaml file and get a new copy that only has the default values set. If it starts up, you can start adding things back until it breaks again.

If you temporarily move or rename the configuration.yaml file and restart HA, it will create a fresh one. I would only suggest a fresh file as a total last resort. There are usually enough error messages in the log files, combined with the hass --script --check_config to track down where your problems are.

Maybe your problem is related to python. When I updated to 0.56, I wasn’t able to start my HASS either. I had to upgrade my virtualenv to python 3.6 (before I had 3.4).
check this link https://community.home-assistant.io/t/python-3-6-upgrade-of-a-virtualenv/21722

1 Like