Unable to Update a Garage Door Opener to ESPHome 2024.2.1

Hi, I’ve been using a Konnected Garage Door Opener for a few weeks now, flashed with the ESPHome firmware. However, it will not update wirelessly from 2023.12.9 to 2024.2.1 due to CMake not being able to locate both the C and CXX Compiler? I’m running HA Green with ESPHome Add-on and below is my YAML setup as well as error log. Any help would be much appreciated.

  name: garage-door-8cefe4
  gdov2_s: github://konnected-io/konnected-esphome/garage-door-GDOv2-S.yaml
  name: ${name}
  name_add_mac_suffix: false

    key: **************************

  ssid: !secret wifi_ssid
  password: !secret wifi_password
Updating /config/esphome/garage-door-8cefe4.yaml

INFO ESPHome 2024.2.1
INFO Reading configuration /config/esphome/garage-door-8cefe4.yaml...
WARNING GPIO3 is a strapping PIN and should only be used for I/O with care.
Attaching external pullup/down resistors to strapping pins can cause unexpected failures.
See https://esphome.io/guides/faq.html#why-am-i-getting-a-warning-about-strapping-pins
INFO Generating C++ source...
INFO Compiling app...
Processing garage-door-8cefe4 (board: esp32-s3-devkitc-1; framework: espidf; platform: platformio/[email protected])
HARDWARE: ESP32S3 240MHz, 320KB RAM, 8MB Flash
 - framework-espidf @ 3.40406.240122 (4.4.6) 
 - tool-cmake @ 3.16.9 
 - tool-ninja @ 1.10.2 
 - toolchain-esp32ulp @ 2.35.0-20220830 
 - toolchain-riscv32-esp @ 8.4.0+2021r2-patch5 
 - toolchain-xtensa-esp32s3 @ 8.4.0+2021r2-patch5
Reading CMake configuration...
-- The C compiler identification is unknown
-- The CXX compiler identification is unknown
-- Configuring incomplete, errors occurred!
See also "/data/build/garage-door-8cefe4/.pioenvs/garage-door-8cefe4/CMakeFiles/CMakeOutput.log".
See also "/data/build/garage-door-8cefe4/.pioenvs/garage-door-8cefe4/CMakeFiles/CMakeError.log".

CMake Error at CMakeLists.txt:2 (include):
  include could not find load file:


CMake Error at CMakeLists.txt:3 (project):
  No CMAKE_C_COMPILER could be found.

  Tell CMake where to find the compiler by setting either the environment
  variable "CC" or the CMake cache entry CMAKE_C_COMPILER to the full path to
  the compiler, or to the compiler name if it is in the PATH.

CMake Error at CMakeLists.txt:3 (project):
  No CMAKE_CXX_COMPILER could be found.

  Tell CMake where to find the compiler by setting either the environment
  variable "CXX" or the CMake cache entry CMAKE_CXX_COMPILER to the full path
  to the compiler, or to the compiler name if it is in the PATH.

========================== [FAILED] Took 8.59 seconds ==========================
===== [ERROR] /config/esphome/garage-door-8cefe4.yaml =====

======================== [SUMMARY] ========================
  - /config/esphome/garage-door-8cefe4.yaml: FAILED

You might try a Pi/HA reboot then try again. If its the same, you might go see if any similar issues have been opened in the Esphome Git or you could ask them on the Discord server for Esphome.

1 Like

Thanks, I’ve rebooted a few times as well as made sure everything else is up to date and still get the problem. I’ve even been able to update other ESP devices, just not this one. Being extremely new to HA, I’m not sure where to turn for help. Being so new, I’m struggling on how to tell if this is a Konnected issue, Home Assistant issue, an ESPHome issue, or a me issue.

Did a quick search, have you tried the Arduino framework as per the last post here

ESPHome install to board fails with CMake error - #3 by bjen

See you are using a ready made package so might be worth contacting konnected.io

1 Like

Yeah, I tried that yesterday, but I’d assume because it’s a package it gives me other new errors related to the range sensor and have sense reverted back. I’m waiting to hear back from Konnected, but wasn’t sure if this was even a Konnected issue opposed to ESPHome or HA.

I didnt even know there was a konnected garage door opener, ive never seen anyone mention them. For 75$ I think they got you if they only added a warning beeper and led… There’s a lot better options out there for half that price. You could make your own with a 25$ Amazon order.

At least you can still use it and its just an issue updating.

Yeah, I’m kind of thinking that too? I was hoping that with me being so new an “off the shelf” solution would save me some headache while still being able to learn something. It ended up being more finicky than I had expected and I probably should have just done a ratgdo opener or something like that. I will report back with what Konnected says.

The thing about the ratgdo is it pulls in all the existing door switches, sensors and light controls for half the price basically. If you look around Google or look on Tindie maybe, you might find cases you can buy for it. Hell, I usually just buy plain “project boxes” on amazon and that what I put stuff in.

Have you tried Clean Build Files under th 3 dot menu for the device on the ESPHome add-on dashboard? This has solved a host of random errors I’ve received while trying to push new firmware, to the point that I frequently just do it out of habit anymore.

Yes, Clean Build didn’t do anything; the error still exists.

This looks like cache files are in a bad state. You probably just need to delete the caches (not the yaml configs).

Specifically I’d suggest clearing out /data/cache/platformio and also the .pioenvs dirs.

1 Like

How would I do that? Search lead me to clearing cache in my browser. I’d assume that isn’t what you meant?

Install the “Studio Code Server” addon.

Use it to browse to the directory config/esphome where you should be able to see a .esphome file.

There’s a directory underneath that with the name of your device - so probably
garage-door-8cefe4. Try deleting that directory.

This is usually enough to clear out any broken cache state and force a complete rebuild by ESPHome - I’ve only had to do it once.

The more involved process would be getting docker access into the container and wiping out the /data/cache/platformio directory next, but you need root access for that (I’m not sure if uninstalling / reinstalling ESPHome would do it).


Thanks! That worked.

The easier method is to re-install the add-on. But if you know how to access the host or container, then that’s good too.