Unable to update Aeotec ZWA039 aerQ Sensor

Hello all,

Forgive me if I’m posting this in the incorrect category.

I have a number of Aeotec ZWA039 aerQ sensors which all have firmware version 2.1.1.

I have now tried to update these but unfortunately it fails. Looking at the Z-Wave JS log I can see the following:

2024-05-30T18:16:23.188Z CNTRLR » [Node 039] Sending firmware fragment 4772 / 4778
2024-05-30T18:16:23.240Z CNTRLR » [Node 039] Sending firmware fragment 4773 / 4778
2024-05-30T18:16:23.292Z CNTRLR » [Node 039] Sending firmware fragment 4774 / 4778
2024-05-30T18:16:23.346Z CNTRLR » [Node 039] Sending firmware fragment 4775 / 4778
2024-05-30T18:16:23.397Z CNTRLR » [Node 039] Sending firmware fragment 4776 / 4778
2024-05-30T18:16:23.450Z CNTRLR » [Node 039] Sending firmware fragment 4777 / 4778
2024-05-30T18:16:23.501Z CNTRLR » [Node 039] Sending firmware fragment 4778 / 4778
2024-05-30T18:16:24.603Z CNTRLR « [Node 039] received wakeup notification
2024-05-30T18:21:23.538Z CNTRLR   [Node 039] The node did not acknowledge the completed update
2024-05-30T18:21:23.539Z CNTRLR « [Node 039] Firmware update (part 1 / 1) failed with status Error_Timeout

I can repeat the update process over and over again, but it always fails. The sensor seems to work, but the battery reporting is not that great. (That is also reported as an issue)

I have also visited the support page where I downloaded the gbl file to try to update the sensor using the “Device Info | Update” possibility. However the result is unfortunately the same.

If anyone has any tips that I could try, that would be very appreciated.

King regards
Magnus

I’ve only updated my ZWA039-A once, and when I did, I placed it near my Aeotec Gen5+ ZStick as the OTA did not work when located in its normal location (1 or 2 hops away). Your situation may be different. If I recall correctly, the sending of a firmware fragment from the controller is acknowledged by the device before another fragment is sent. It kind of looks like your device is getting the download, but maybe it doesn’t like the file (either its corrupted or the wrong type).

Thank you very much Tommy for your answer.

I originally had the sensor approximately 2 meters away (about 6.5 feet) from my Aeon Labs ZW090 Gen5 stick. I have now placed the sensor less than 1 inch away from the controller and tried to update again. I did not time the time it takes to download the fragments , but maybe it was a little bit quicker. However, the error remains the same :cry:

If the file is incorrect, it seems to be so in both “Update device” section

and in the Updates section

Maybe send a question to Aeotec support to see what they say.

Yes, I probably will have to do that !

I had the same issue, finally I succeeded using a second USB stick plugged in my PC and using Simplicity Studio - Silicon Labs

So, yes I needed to exclude en include them again, but by renaming the same names by reinclusion I did not lost any config or automations.
The firmware update went smooth, 7 devices, every one updated on first shot.

And, watch out, during the firmware update you need to keep them AWAKE by pressing the button every while… When they fall in sleep, they stop receiving :wink:

Hello BebeMischa,

I contacted Silicon Labs and they also suggested Simplicity Studio 5. So I created an account and downloaded the application. Unfortunately there is some kind of bug in the app which prevents me from logging in (there is always only a white area where I suppose that the username and password should be entered) and thus I can’t use the application the way it is intended. I’m sure that SiLabs support will help me overcome this small nuisance… :innocent:

1 Like