Unable to Update Community Add-Ons in Supervisor after Security Update

I have been getting this for about a week now.

Failed to install addon

500 Server Error for http+docker://localhost/v1.40/images/create?tag=3.0.0&fromImage=ghcr.io%2Fhassio-addons%2Fvscode%2Famd64: Internal Server Error (“Get “https://ghcr.io/v2/”: dial tcp connect: no route to host”)

I do have not made any network changes in the past months and have been running multiple VLANS following this post.

have no Idea where to go from here as both VLANS are open to the internet.

I ran into this today actually. Not with an add-on, I tried to update supervisor today and saw the same message with a docker url.

I only saw it when trying to click the update button in the UI though. My update notifications include an “update” action which when clicked uses a command line notify to make a call to the matching Supervisor REST API to update whatever component needs updating. When I used that option from the notification it worked fine.

So maybe it’s something wrong with the UI? Did you try updating the add-on via the CLI?

I am not familiar with updating or installing add-ons via the CLI. I looked for the commands a bit but couldn’t find the commands or steps to try that. I am running HASSIO on a Virtual Machine.

If you have one of the ssh add-ons installed you can ssh in and run this.

 ha addons update core_ssh

Just replace core_ssh with the slug of the add-on you want to update. If you open the add-on in the UI the slug appears in the URL. Basically click on any addon from the supervisor panel and the url is /hassio/add-on/{slug}/info. That slug is the id your looking for for the CLI. You can also run the command ha addons to see a list of all your add-ons and their slug field.

Also just an FYI, hassio isn’t an install method. The four install methods are here. Since you have add-ons that means you either have a Home Assistant or Home Assistant Supervised deployment. I know it’s a bit confusing since the name of the install method is the same as the application but just wanted to let you know in case you end up having to open an issue in github since you’ll need the correct name.

Thanks. Unfortunatly that did not work. I get the same error. No idea what it could possibly be. Even restored to 3 week old snapshot and have the same issue…

Well shoot, that is unfortunate, I’m not really sure how to help then. I’d suggest heading over to the Home Assistant server on discord in that case (https://discord.gg/c5DvZ4e). There’s a channel specifically dedicated to questions/issues with add-ons as well as a channel per installation method.

I think that’ll probably be your fastest way to get to people with knowledge of how to fix this. The developers are very responsive in that server in my experience.

Disc/card full?

Supervisor says 22%. Also just in case I had deleted the home-assistant-v2.db file which was about 1gb. Still not doing anything.

Okay I got a little progress I believe but still not sure where to go.
I found items like Community Add-Ons like ESPHome installs with no issue. I assume its not a docker container using the internal docker container dns of

However all fails and reference “https://ghcr.io/v2/”: dial tcp connect: no route to host"

From terminal plugin in HA I can’t ping
From cmd in windows I can.

Found the error when running terminal in HA
~$ traceroute
traceroute to (, 30 hops max, 46 byte packets
** 1 d7b954-nodered.local.hass.io ( 0.004 ms 0.003 ms 0.001 ms**
** 2 ( 3081.201 ms !H 3070.861 ms !H 3071.967 ms !H** is my actual VLAN IP of the Homeassitant. Anyone know how to get this directed to the correct dns of

In my network setting under supervisor host I have (2) IP’s

eth0 - DHCP (Its static on my router
eth0.20 - Static (IP:, Gateway:, DNS:

FIXED THIS ISSUE. I had the VLAN20 set to Needed a subnet mask of 24 and all works great now.