Unable to Update Supervisor, system unhealty

Tags: #<Tag:0x00007fc3ef0b56c0> #<Tag:0x00007fc3ef0b55f8>

I recently did a brand new install of HA Operating System, with the Balena Etcher, running on a new pi4 4gb. Install and start up went smoothly, I can access HA from the local link, I connected it with Philips Hue to test it out and it works as it should. However, I am unable to update the supervisor, any time I try from either the supervisor tab, or from the CLI on the Pi itself I get the follow output:

21-06-04 00:33:22 INFO (SyncWorker_1) [supervisor.docker.interface] Downloading docker image homeassistant/aarch64-hassio-supervisor with tag 2021.05.4.
21-06-04 00:33:24 ERROR (SyncWorker_1) [supervisor.docker.interface] Can’t install homeassistant/aarch64-hassio-supervisor:2021.05.4 → 500 Server Error for http+docker://localhost/v1.40/images/homeassistant/aarch64-hassio-supervisor:2021.05.4/json: Internal Server Error (“readlink /mnt/data/docker/overlay2/l: invalid argument”).
21-06-04 00:33:24 ERROR (MainThread) [supervisor.supervisor] Update of Supervisor failed!

Reloading/restarting supervisor or anything else has no effect, neither does completely rebooting the Pi. I even tried doing a completely fresh install on the SD card, but went right back to where I am now.

Well, did yet another complete reinstall and it installed the newest version, so all is well for now.

Update of Supervisor failed: Can’t install homeassistant/aarch64-hassio-supervisor:2021.06.0: 404 Client Error for http+docker://localhost/v1.41/images/homeassistant/aarch64-hassio-supervisor:2021.06.0/json: Not Found (“no such image: homeassistant/aarch64-hassio-supervisor:2021.06.0: No such image: homeassistant/aarch64-hassio-supervisor:2021.06.0”)

My experience matches yours. I hope a complete reinstall isn’t the only way out.

Check your disk space.

You should be able to create a backup, reinstall then restore. Hopefully. I didn’t bother since I had just started.

1 Like

This was a brand new install on a 64gb SD card. Disk space for me wasn’t an issue, it just wouldn’t connect for the download. Reinstalling ended up installing the new version of supervisor, haven’t tried to update since then

Docker overlay has been corrupted.

run ha supervisor repair

Repair completes without error, but update still fails. :frowning:

HA says I’m using 7% of 64GB, so unless there is some strange partitioning going on, disk space isn’t the problem.

Having the same issue following os 6.0 update on Rpi4 with 120gb SSD.