Unable to update to 0.70.1

Hey gang,

I recently received a notification that version 0.70.1 was out, so I logged in to update like normal but am unable to do so.

core-ssh:~# hassio ha update
panic: interface conversion: interface is nil, not string

goroutine 1 [running]:
panic(0x2c7050, 0x1070b620)
        /home/travis/.gimme/versions/go1.7.6.linux.amd64/src/runtime/panic.go:500 +0x33c
github.com/home-assistant/hassio-cli/command/helpers.DisplayOutput(0x107b6200, 0x24, 0x200, 0x0)
        /home/travis/gopath/src/github.com/home-assistant/hassio-cli/command/helpers/common.go:118 +0x3c8
github.com/home-assistant/hassio-cli/command/helpers.ExecCommand(0x2f6f83, 0xd, 0x7ebf5e64, 0x6, 0x0, 0x0, 0x76500, 0x0, 0x0, 0x0, ...)
        /home/travis/gopath/src/github.com/home-assistant/hassio-cli/command/helpers/common.go:155 +0x308
        /home/travis/gopath/src/github.com/home-assistant/hassio-cli/command/homeassistant.go:48 +0x540
github.com/urfave/cli.HandleAction(0x2af768, 0x324b14, 0x10778580, 0x0, 0x0)
        /home/travis/gopath/src/github.com/urfave/cli/app.go:503 +0xf0
github.com/urfave/cli.Command.Run(0x2f6f83, 0xd, 0x0, 0x0, 0x40bd10, 0x1, 0x1, 0x301e4d, 0x2f, 0x0, ...)
        /home/travis/gopath/src/github.com/urfave/cli/command.go:165 +0x6b8
github.com/urfave/cli.(*App).Run(0x107648c0, 0x1070a160, 0x3, 0x4, 0x0, 0x0)
        /home/travis/gopath/src/github.com/urfave/cli/app.go:259 +0x8b0
        /home/travis/gopath/src/github.com/home-assistant/hassio-cli/main.go:22 +0x108

core-ssh:~# hassio ha info
    "result": "ok",
    "data": {
        "version": "0.69.1",
        "last_version": "0.70.1",
        "machine": "raspberrypi3",
        "image": "homeassistant/raspberrypi3-homeassistant",
        "custom": false,
        "boot": true,
        "port": 8321,
        "ssl": false,
        "watchdog": true,
        "wait_boot": 600


I just rebooted to see if that fixes the issue but am still unable to complete the upgrade. any advice? i’m not really sure where to even begin with this one.

Use the interface to update (using chrome) and check system tab on the ui for log saying when tagging is complete so you don’t reboot by mistake mid-pull

well update: looks like rebooting it may have been the wrong thing to do. now nothing is coming up. the frontend will not load at all. I can connect via SSH but that’s it. cant run any commands on it, they all come back with the same ERROR panic: interface conversion: interface is nil, not string

what the hell happened? how can I untangle this?

Can you do a few commands?

hassio --version

hassio su logs

hassio -d ha info

I got exactly the same error when trying to update using SSH.

When updating thru the interface i’ve got the following error in my systemlog:

18-06-05 07:53:52 INFO (MainThread) [hassio.api.security] /homeassistant/update access from 
18-06-05 07:53:52 INFO (SyncWorker_11) [hassio.docker.interface] Update docker 0.69.1 with 
18-06-05 07:53:52 INFO (SyncWorker_11) [hassio.docker.interface] Pull image homeassistant/raspberrypi3- 
homeassistant tag 0.70.1.
18-06-05 08:05:08 ERROR (SyncWorker_11) [hassio.docker.interface] Can't install 
homeassistant/raspberrypi3-homeassistant:0.70.1 -> 404 Client Error: Not Found ("no such image: 
homeassistant/raspberrypi3-homeassistant:0.70.1: No such image: homeassistant/raspberrypi3- 

hassio version 1.3.1

DEBUG [CmdHomeassistant]: action->'info', endpoint='info', serverOverride->'', GET->'true', options->'', 
rawjson->'false', filter->''
DEBUG [ExecCommand]: basepath->'homeassistant', endpoint->'info', serverOverride->'', get->'true', 
Options->'', Filter->'', RawJSON->'false'
DEBUG [GenerateURI]: basepath->'homeassistant', endpoint->'info', serverOverride->''
DEBUG [RestCall]: data->'http://hassio/homeassistant/info', GET->'true', payload->''
DEBUG [RestCall]: ResponseBody->'{"result": "ok", "data": {"version": "0.69.1", "last_version": "0.70.1", 
"machine": "raspberrypi3", "image": "homeassistant/raspberrypi3-homeassistant", "custom": false, "boot": 
true, "port": 8123, "ssl": true, "watchdog": true, "wait_boot": 600}}'
"result": "ok",
"data": {
    "version": "0.69.1",
    "last_version": "0.70.1",
    "machine": "raspberrypi3",
    "image": "homeassistant/raspberrypi3-homeassistant",
    "custom": false,
    "boot": true,
    "port": 8123,
    "ssl": true,
    "watchdog": true,
    "wait_boot": 600

Is there another way to upgade without having to start all over.

I’m having the same issue/error messages when I try to update via ssh. I’m unable to access Hass.io from the iOS app, it just gives a blank white screen, and when I try via web browser (Chrome, IE11) and click the button to update, it fails (button turns red).

I’d hate to start from scratch…any insight is appreciated.

I’m also running 0.69.1 on an rpi3…

I had the same error when updating. In my case, there was not enough free space for the update. After clearing the free space, the update was successful. To update it took about 1.3 GB of free space.

Interesting. Thanks for the reply. I’m using a 32GB SD card in which only 10% is currently being used.

In the mean time i was able to update to the latest version. Had enough free space on my 64GB SD card. But had a problem on my network / internet connection. This has been solved an updated without any problem.