Unable to update to latest release 0.67

Nothing happens by the UI and when i try from the ssh prompt i get this error:

core-ssh:~# hassio homeassistant status
No valid action detectedcore-ssh:~# hassio homeassistant update
panic: interface conversion: interface is nil, not string

goroutine 1 [running]:
panic(0x2c5f60, 0x107b44a0)
/home/travis/.gimme/versions/go1.7.6.linux.amd64/src/runtime/panic.go:500 +0x33c
github.com/home-assistant/hassio-cli/command/helpers.DisplayOutput(0x107c0200, 0x24, 0x200, 0x0)
/home/travis/gopath/src/github.com/home-assistant/hassio-cli/command/helpers/common.go:118 +0x3c8
github.com/home-assistant/hassio-cli/command/helpers.ExecCommand(0x2f5e63, 0xd, 0x7ee11e61, 0x6, 0x0, 0x0, 0x76000, 0x0, 0x0, 0x0, …)
/home/travis/gopath/src/github.com/home-assistant/hassio-cli/command/helpers/common.go:155 +0x308
/home/travis/gopath/src/github.com/home-assistant/hassio-cli/command/homeassistant.go:48 +0x540
github.com/urfave/cli.HandleAction(0x2ae6d8, 0x323754, 0x10780420, 0x0, 0x0)
/home/travis/gopath/src/github.com/urfave/cli/app.go:503 +0xf0
github.com/urfave/cli.Command.Run(0x2f5e63, 0xd, 0x0, 0x0, 0x409d10, 0x1, 0x1, 0x300cfa, 0x2f, 0x0, …)
/home/travis/gopath/src/github.com/urfave/cli/command.go:165 +0x6b8
github.com/urfave/cli.(*App).Run(0x1076c8c0, 0x1070a160, 0x3, 0x4, 0x0, 0x0)
/home/travis/gopath/src/github.com/urfave/cli/app.go:259 +0x8b0
/home/travis/gopath/src/github.com/home-assistant/hassio-cli/main.go:22 +0x108

Any suggestions what can be wrong? running Hassio 0.66.1

1 Like

I’m also encountering this same error. I’ve tried reloading the supervisor, and I’ve tried shutting down, unplugging the RPi, and powering it back up, but this error still occurs.

I finally got it working here.

I shut down Hass.io from the CLI, deleted home-assistant_v2.db, started Hass.io again, and then ran the update from the CLI again. Took several minutes, but it eventually completed the update and restarted Hass.io.

My was related to broken SD-Card

HassIO will act very strange if the SD card is too full and it doesnt have room to play. I use the following to keep the DB file size down so that doesnt happen (after learning the hard way of course!)


  purge_interval: 1
  purge_keep_days: 7
1 Like

Ahh, I was just wondering if there was a way to keep the DB file down to a reasonable size. Thanks!

Just hit this exact same issue.

I clicked Update on the WebUI, sat there spinning for awhile.

SSH to the hassio instance. Top shows nothing is going on. Issue manual update: hassio ha update. Get the exact same error as OP.

Google around for 20min hoping for answers. Suddenly it is updated to 0.67 and working fine. This is the most common answer I saw searching for this: Do nothing, just wait, can take awhile.