Unable to upgrade Core to 2021

Tags: #<Tag:0x00007f325cc6daf0>
ERROR (SyncWorker_4) [supervisor.docker.interface] Can't install homeassistant/raspberrypi4-homeassistant:2021.2.3 -> 500 Server Error for http+docker://localhost/v1.40/images/homeassistant/raspberrypi4-homeassistant:2021.2.3/json: Internal Server Error ("readlink /mnt/data/docker/overlay2/l: invalid argument").
21-02-22 05:56:59 WARNING (MainThread) [supervisor.homeassistant.core] Updating Home Assistant image failed

Tried upgrading to 2021.1.5 and got the same result.
I am upgrading from 0.116.4

Solved my own issue with:

ha su repair

apparently I was missing a file or 2

Leaving this here if anyone is searching for a 500 Server Error when trying to upgrade/update the core to a newer version.