Unable to upload the compiled firmware to ESP32

Hi, I have DHT22 sensor running fine with the ESP32 board in ESPHome and today I want to calibrate it by adding the filters section into my config file and it passes the validation.

When I want to upload it wirelessly to the ESP32 board, it fails with the following error message.

I’m still running with ESPHome v2021.10.3 and this version is fine previously when I’m adding the DHT22 sensor.

Do I have to update the ESPHome to resolve the error? Also, I don’t see an update option in the ESPHome addon. So, may I know how to update it?


1 Like

Try to clean-compile → click on three dots (on home page of esphome addon), select “clean build files” and compile again.
As for esphome addon: you must add a repo: read this

I am having the same error. It happens when I try to upload to any of my ESP boards, even if I have not made any changes to the currently working code.

What ESPhome version are you running?

I’m suspecting the problem is due to old version of EPShome, though I have not tried again with the latest EPShome as I have not updated the ESPhome yet.

I have tried to clean the compile library as suggested by @Protoncek , but it didn’t help.