Home Assistant Community

Unable to use tracking/notifications on latest version (58)

beta-testing
Tags: #<Tag:0x00007fcf5ad46fd0>
#1

After update I noticed that I wasn’t getting any notification, I reimported the push configuration from the server, still nothing.
I then removed IOS component, still nothing, I deleted the content of known devices.
discovery is on
I am also using hassio beta
Should I revert back to an old version, get the devices recognized and then upgrade?

thank you

#2

new iOS 2 doesn’t use ios: anymore - uses mobile_app:
I am using it with hassio beta as well with no problems.
You might need to enable zero_conf: in config to get it running. Also check the iOS channel on Discord for help.

1 Like
#3

Thank you David! I will check right away!

#4

check also the docs here https://companion.home-assistant.io/en/

1 Like
#5

I had already default_config: in configuration, I now remember adding it few beta ago. It should also load mobile_app: and zeroconfig
{
“domain”: “default_config”,
“name”: “Default config”,
“documentation”: “https://www.home-assistant.io/components/default_config”,
“requirements”: [],
“dependencies”: [
“automation”,
“cloud”,
“config”,
“conversation”,
“frontend”,
“history”,
“logbook”,
“map”,
“mobile_app”,
“person”,
“script”,
“sun”,
“system_health”,
“updater”,
“zeroconf”
],
“codeowners”: []
}

#6

ok so.
You will need to restart HA and also add the mobile app as an integration.
The device tracker is a nasty name with the UUID
Are you getting a push_id?
I think the trick is restarting HA after you add this then as long as you have a push_id, you should get a new notification device.

See also the docs

1 Like
#7

I get notification now, push id ok, tracker still missing in action, I remember deleting them from known devices.
I don’t also get Actionable notifications,
I had this under ios: in configuration.yaml , btw the docs aren’t active, I get page not found.

ios:
push:
categories:
- name: stairslights
identifier: stairslights
actions:
- identifier: STAIRSOFF
title: “Turn Off Stairs Lights”
activationMode: ‘background’
authenticationRequired: no
destructive: yes
behavior: ‘default’

#8

I think you still need the old ios: if you use actionable notifications (at least you did). I don’t use them so I don’t know.

Check your entities in the dev tools… device_tracker.great-big-long-unfriendly-UUID

1 Like
#9

The docs are active. Try the link in the bar at the top, not the ones on the page… I just reported the dead links and they are being fixed but the bar at the top links work

1 Like
#10

After a reset of the app, usual restart of HA, both trackers reappeared (iphone and ipad)

Thank you for the help, also watch app it is installing now