Unable to use wall switch after Tasmota flashed light is turned off via HA

Tags: #<Tag:0x00007f739ee15eb0> #<Tag:0x00007f739ee15938>

Hopefully someone can take me out of misery as I have literally lost sleep over this… :sleeping:

Long story short, flashed bunch of Tuya globes to Tasmota 8.1.0.2 yesterday and all went well I thought. Lights were re-integrated into HA by MQTT auto discovery and all is working as intended from HA point of view.

The issue was identified when I tried to turn the light on at the wall switch; light that was previously turned off via HA. To my surprise, flicking the switch off and back on resulted in globe briefly flickering on but staying off ultimately. If I turn light back on via HA then physical wall switch works as intended.

I have followed few guides around the place dealing with dreaded retain settings and else but nothing has worked so far.

How does one override this behaviour so wall switch turns light on/off irrespective of the state in HA?

I am not sure if I should be laughing or crying right now but appear to have found solution to my problem. Solution was a single console command:

PowerOnState 1

That’s the single setting requiring change as it now works with other globes that had default settings after flashing.