Unable to View Live Camera Feed on Mobile Data

Hello!

I’m currently using Nabu Casa to connect to HA when I’m out of my house.

I’ve setup multiple cameras using the Frigate Lovelace Card (WebRTC). They work perfectly on my Android phone both on wifi and on mobile data, but on my iPhone they only work on wifi. As soon as I use mobile data it’s just a black display where the feed would be.

I’m able to view and play recorded clips, but the live view does not work.

I’ve also tried to set up the cameras just using WebRTC without the Frigate card and I get the same result.

Is there a configuration or some setup I’m missing that will allow me to view the live video on mobile data?

Thanks!

Taken from the documents:

Q. Exernal access with WebRTC doesn’t work

A. WebRTC technology can’t use your HTTP/HTTPS-access to Hass. It uses a random UDP port to connect. And it can handle access to stream even if you have private IP-address, but not in all cases.

At each start of the streaming, a random UDP port is occupied. The port is released when the streaming ends. The data should theoretically be encrypted, but I haven’t tested :slight_smile:

If your stream does not start with an external connection, you may be behind a symmetric NAT.

Read how to fix this.

For more tech info read about STUN and UDP hole punching.

1 Like

Hi Rossk,

I appreciate the response! Unfortunately that is about webRTC not working at all, but it works fine on Android so this is a more iOS specific issue. I did find this related thread https://github.com/AlexxIT/WebRTC/issues/246 which sounds like the exact issue I’m having. I think there is a wider audience here so I’m hoping someone found a solution or workaround.

Thanks!

1 Like

Did you find a solution to this? I have this exact issue and the weirdest thing is that an older iPhone seems to work ok with webRTC off the local network! I’m having lots of problems with the Frigate card in general on iOS so I’m looking elsewhere.

I have it working more of the time using go2rtc GitHub - AlexxIT/go2rtc: Ultimate camera streaming application with support RTSP, RTMP, HTTP-FLV, WebRTC, MSE, MJPEG, HomeKit, FFmpeg, etc.. go2rtc will be built into frigate in the next release though, not sure if you want to wait for that.

1 Like

Thanks for the heads-up. I’m testing the beta addon on HA OS and I’m still having trouble on iOS. I’ve forwarded port 8555 to my HA instance and put my external IP as a candidate in the webrtc config of frigate but it’s still not working.